Bug #987

Sound going on and off

Added by Alexandre Zia almost 9 years ago. Updated over 8 years ago.

Status:FixedStart date:05/06/2012
Priority:NormalDue date:
Assignee:Alexandre Zia% Done:

0%

Category:Audio
Target version:4.0
Found in version:several, latest included Platform:PS3

Description

Sometimes sound keeps deactivating and reactivating and the video stutter.
I can see it changing from 5.1 to stereo
Using latest development version of showtime.
My PS3 is using optical audio out.
I've attached a sample file, this shows up in the first 2:30 minutes.

sample.mkv - sample audio stuttering (100 MB) Alexandre Zia, 05/06/2012 10:07 PM

sample35MB.mkv (35 MB) Cyndi Landa, 08/05/2012 10:21 PM

sample35MB.mkv (35 MB) Cyndi Landa, 08/05/2012 10:31 PM


Related issues

Duplicates Bug #1063: [PS3] Stuttering Playback of a Video, when audio track ch... Fixed 07/30/2012
Duplicates Bug #1037: no sound after seeking Fixed 06/17/2012

Associated revisions

Revision 444579ec
Added by Andreas Smas over 8 years ago

Fix a bug that caused audio channels configuration to be unstable

Fixes #1063
Fixes #987

Change included in version 3.99.450

History

#1 Updated by Tony Miker almost 9 years ago

FYI: I changed my PS3 audio settings from Optical Digital to HDMI, and the "AUDIO (DEBUG): PS3 audio port 0 opened /AUDIO (DEBUG): The state is 1" glitch still occurs. With sound going to my TV through HDMI the glitch is actually a bit worse as it often sounds like a burst of static. When sound is set to use an optical connection to my stereo the stutter is silent.

Also, here's the thread with the original reports

#2 Updated by Andreas Smas almost 9 years ago

  • Target version set to 4.0

#3 Updated by Andreas Smas almost 9 years ago

  • Status changed from New to Accepted

Argh! I'm reading the Game of Thrones books. Don't want to ruin it by watching this :-)

#4 Updated by Andreas Smas almost 9 years ago

Seems the problem is that the audio tracks switches between stereo and 5.1

#5 Updated by Andreas Smas almost 9 years ago

Are there no other samples that have this issue?
Watching that recap kinda ruined my day :-(

#6 Updated by Andreas Smas almost 9 years ago

  • Status changed from Accepted to Need feedback

#7 Updated by Alexandre Zia almost 9 years ago

Men I'm sorry for the spoil ...

#8 Updated by K B almost 9 years ago

This issue is common with many of HD MKV rips of GOT. During the recap the sound is in stereo and keeps cutting out. After the HBO logo the sound switches to 5.1 and everything is fine.

#9 Updated by Tony Miker almost 9 years ago

I think this issue is related to the size and/or state of certain buffers, which is why I've only seen it with 720p and higher videos. Let me explain.

I've had trouble making small sample files that cause the glitch. I had (incorrectly) guessed that TSmuXer or MKVToolNix might be "repairing" the audio stream when making my samples, so I switched to using the unix command "split" to preserve the exact binary.

"split -b 15M" and "split -b 30M" made 15 MB and 30 MB samples that played fine.
"split -b 40M" made a sample with immediate audio glitches.
"split -b 35M" made a sample with audio glitches, however they lasted only a few seconds (in comparison to the 40 MB sample) until the packet buffer (viewed with L3) started to empty.

So it looks filling the packet buffer is neccessary to cause this bug. Unfortunately, 35 MB exceeds my upload capacity right now, but I'll try to work something out.

#10 Updated by Andreas Smas almost 9 years ago

  • Status changed from Need feedback to Accepted

Interesting observation. I'm not having access to my PS3 this week so I can't test more right now

#11 Updated by Cyndi Landa over 8 years ago

This bug is annoying. I've found that it can be worked around a bit by setting the PS3 audio output to stereo only (in XMB), but it does still occur. I've attached another sample in case you still don't want spoilers for your books :)

#12 Updated by Cyndi Landa over 8 years ago

This bug is annoying. I've found that it can be worked around a bit by setting the PS3 audio output to stereo only (in XMB), but it does still occur. I've attached another sample in case you still don't want spoilers for your books :)

#13 Updated by Andreas Smas over 8 years ago

Ok, great :-) I've read the book during the summer and i'm now actually watching GOT S01.

I'll have a look at this issue during the week

#14 Updated by Andreas Smas over 8 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF