Feature #812

Plugin Dependencies

Added by Fábio Ferreira almost 9 years ago. Updated over 5 years ago.

Status:RejectedStart date:12/17/2011
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:Plugins
Target version:4.10

Description

It would be helpful if there was a dependency checker before installing a new plugin (in a similar way than apt-get or yum), maybe with some field in plugin.json separated in commas the several plugins it requires. And if user would want to install the new plugin and don't have the others, the others could download too first.


Related issues

Related to Feature #866: URI handler exists Fixed 02/04/2012

History

#1 Updated by Andreas Smas almost 9 years ago

  • Target version changed from 3.4 to 33

#2 Updated by Andreas Smas almost 7 years ago

  • Target version deleted (33)

#3 Updated by Leonid Protasov over 6 years ago

  • Priority changed from High to Normal

#4 Updated by Leonid Protasov over 5 years ago

  • Status changed from New to Need feedback
  • Target version set to 4.10

IMHO that just should be mentioned by plugin author in popup or something if it's really the issue.

#5 Updated by Leonid Protasov over 5 years ago

#6 Updated by Andreas Smas over 5 years ago

  • Status changed from Need feedback to Rejected

Also available in: Atom PDF