Bug #750

high quality mkv (+20gb)

Added by D Z over 9 years ago. Updated over 9 years ago.

Status:FixedStart date:10/22/2011
Priority:HighDue date:
Assignee:Andreas Smas% Done:

100%

Category:Video playback
Target version:3.4
Found in version:all versions Platform:PS3

Description

Will showtime in the future be able to handle mkv that are more than 20 gb big?
or hasnt the ps3 enough power.
When i now start to watch a remux version of a film, video and audio are async and the fps are very low (stuttering).

world_invasion.txt Magnifier (5.99 KB) D Z, 10/25/2011 01:03 PM

avatar.txt Magnifier (9.35 KB) D Z, 10/25/2011 01:03 PM

Braveheart.1995.1080p.BluRay.FLAC.sample.mkv - braveheart 34sec sample (152 MB) Ca Ra, 11/30/2011 10:37 PM

Associated revisions

Revision 2f088a77
Added by Andreas Smas over 9 years ago

ps3: Various fixes for problems with cell accelerated h264 playback

Fixes #729
Fixes #750

Change included in version 3.3.380

Revision 5536a8b4
Added by Andreas Smas over 9 years ago

ps3: Fix regression from last commit (seek caused picture order problems)

refs #750

Change included in version 3.3.382

History

#2 Updated by D Z over 9 years ago

i know that showtime has problem with format profile of 5.1 and it cant handle many reframes. but all my remux mkvs have max 4.1 and not mare than 4 reframes.
here is an excerpt of transformers:

Format : AVC
Format/Info : Advanced Video Codec
Format profile :
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 34mn
Bit rate mode : Variable
Maximum bit rate : 34.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive

#3 Updated by Jérôme S. over 9 years ago

You should had started with that.

Do you read it through dlna/samba ? I think your bitrate is too high for your local network & maybe ps3 too.

#4 Updated by Ca Ra over 9 years ago

I can confirm this happens aswell. (big files and/or remuxes)

some play OK (even with 24 bit FLAC).
others will crash the player or give no video.

all are compliant (<4.1).

btw, one can't fast forward a mpeg-2 remux.

using samba - latest version (yesterday)

#5 Updated by D Z over 9 years ago

Im also using latest unofficial version of showtime. I stream the filea via samba. Ive got a gigabit network and i have done the registry trick in windows 7 (disabled nagle).

#6 Updated by Rusty Unknown over 9 years ago

Have you tested the file from the PS3's internal HDD? I would try that to determine if its a streaming problem or not.

If your host media device is streaming through the router, you must consider the transfer speed of the router. The router speed is much slower than the actual ethernet cable in most cases.

If it is hosted from a PC, it would be better to connect the PC directly to the PS3 via ethernet, and bypass the router.

#7 Updated by Ca Ra over 9 years ago

In my case. they are directly connected (gigabit on both ends) with a cable (no man in between).

I have also tried with an external hdd and it also happens (one video).

like I said, some big files play, others don't.

the difference I notice is that the ones that don't play have very high bitrates (remuxes ~30-40 Mbps)

#8 Updated by Jérôme S. over 9 years ago

Already said on another topic but the level of a video (4.1/5.0/...) depends of a lot of things : bitrate, reframe, ....
Some encoder put the right level regarding to all the encoding parameters, some do NOT. It happens that a video mark as 4.1 is in fact a higher level regarding its size, bitrate, reframe, ...

Maybe the vidz that do not work are in that case.
Use Mediainfo to fetch all data of a sample that works, and another that does not, and find the differences.

#9 Updated by D Z over 9 years ago

I tested all files via samba and internal HDD - still stuttering.
I found a movie that plays well... Avatar. I made a mediainfo txt file of avatar (works) and worldinvasion battle los angeles (doesnt work). both have a comparable bitrate, use 4.1 and have 2 reframes.

I dont think that bandwidth is the limiting factor.

#10 Updated by Jérôme S. over 9 years ago

Only differences I see is that avatar sound is in 24bit instead of 16bit in batlle of LA and this :

Format_Settings_GOP : M=3, N=24

found in avatar. I don't know what is this propertie.

Check for sound and this.
Try quit and restart showtime each time you test a video, it will clear memory and stuff I suppose.
If a video as big as avatar plays well on your config, other should pass, so it's not a network problem, neither a file size issue, I suppose.

#11 Updated by Jérôme S. over 9 years ago

ok GOP is Group of Pictures, and it says 24 ips with a distance of 3 from I or P to P

#12 Updated by Ca Ra over 9 years ago

like I said, in my case, these are remuxes from the original BD.
So the video must be within 4.1.

#13 Updated by Jérôme S. over 9 years ago

You should test in internal HDD or DLNA to find if it's not a samba related bug.

Differences within sharing protocol or videos properties is the only way to find what's wrong.

#14 Updated by D Z over 9 years ago

Like i said, i already tested with internal hdd still no luck. With ps3 media server it works, because it transcodes all mkvs to ps3 compatible formats. If i use ts muxer it is sync and no stuttering but there are some anoying artifacts, so it isnt watchable either.
Streaming through pms works if i use mencoder but i wont get the best quality.

#15 Updated by Andreas Smas over 9 years ago

  • Status changed from New to Accepted

#16 Updated by Andreas Smas over 9 years ago

  • Status changed from Accepted to Rejected

I use the BBC.Invisible.World.I.2010.1080p.BulRay.x264.DTS-HDChina.mkv file which probably can be obtained from any file sharing site near you.
It is properly encoded and 13Mbps on average, sometimes peaking at 40Mbps

No problem to play back at all.

It certainly does not play when hooked up over WiFi but when HTTP streaming it works just fine.

I just don't have time to search the internet for various files that does not play.

Sorry

#17 Updated by Ca Ra over 9 years ago

when I mean heavy, I mean average 30Mbps video (braveheart remux is the one I notice the most).

#18 Updated by Jérôme S. over 9 years ago

Do you have gigabit network Ca Ra ?

#19 Updated by Ca Ra over 9 years ago

Yes I do. maybe Thursday I'll post a sample if braveheart (if there's interest) and test it to see if it happens on it aswell.

#20 Updated by Ca Ra over 9 years ago

Here it is. (tested and the stuttering happens)

#21 Updated by Andreas Smas over 9 years ago

  • Status changed from Rejected to Accepted

Thanks for the sample.

It seems this is a problem with the timing of frames in Showtime rather than a problem with the decoder itself.

So it's certainly fixable, i'm not sure how to fix it yet

#22 Updated by Ca Ra over 9 years ago

Good to hear it helped.

I noticed that I can't FF on mpeg-2 remuxes. they play fine, but you can't FF one bit.
Also, why is there no vc-1 internal decoder support? are you using ps3 game API (no vc-1) or direct blu-ray video API (all 3 codecs)?

#23 Updated by Andreas Smas over 9 years ago

Yeah I'm using the in-game API i guess. No idea how to access the bluray api.

#24 Updated by Andreas Smas over 9 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100

#25 Updated by Ca Ra over 9 years ago

It's fixed!

But, there is a new bug (that should be easy to fix).
If you ff on any video, some frames from the original position are still in the buffer, causing a glitch every few seconds.
it's very noticeable. just ff on any video (tested on 1080p mkv's).

good work, Andreas!

PS: where did you got the original cell internal decoder code from? I recollect a .zip almost a year ago with video code appearing on the web, but I can't find it.

#26 Updated by Girish Patel over 9 years ago

I've noticed the glitch too.

Also available in: Atom PDF