Bug #721

L5.0/5.1 MKV no video playback

Added by Jeff Miller over 9 years ago. Updated over 9 years ago.

Status:RejectedStart date:09/24/2011
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Video playback
Target version:3.4
Found in version:3.3.045 Platform:PS3

Description

Almost all(very few work) of my MKV which have a lvl of 5.0 or higher do not display video, but the subtitles and sound work. I have tried using various programs to change the lvl of the mkv and remux them but it still does not work. I am assuming the level is the problem as it is the only difference I can find between the files, unless anyone else can spot a different issue. Attacked a non-working/working file to compare.

To_Aru_Kagaku_no_Railgun_-_03__1280x720_.mkv - Does not play (51.2 MB) Jeff Miller, 09/24/2011 03:01 PM

To_Aru_Kagaku_no_Railgun_-_02__1280x720_.mkv - Plays correctly (50.1 MB) Jeff Miller, 09/24/2011 03:01 PM

History

#1 Updated by Girish Patel over 9 years ago

The file that does not play has this info:

Format profile :
Format settings, CABAC : Yes
Format settings, ReFrames : 16 frames

Where the file that does play has this info:

Format profile :
Format settings, CABAC : Yes
Format settings, ReFrames : 3 frames

The difference is the ReFrames level. 16 is too high.
The highest mkv Reframe value I've got to play in Showtime is 10 with a profile of 4.1
Level 5.0 and 5.1 mkv files play ok with low ReFrame values. I've noticed a few CPU too low messages lately or Showtime drops the level to 4.2 message with 5.0 and 5.1 profiles.

#2 Updated by Jérôme S. over 9 years ago

You should by a PC or claim Sony for a more powerfull PS3.
I dont know if Andreas could do something about that.

#3 Updated by Ajith Thampi over 9 years ago

Jérôme S. wrote:

You should by a PC or claim Sony for a more powerfull PS3.
I dont know if Andreas could do something about that.

Actually showtime should definitely do something about this.something as small as a message should do.
A meaningful message stating 'reframe' level in-compatibility on ps3 does wonders to normal users.
I have seen this issue pop quite a few times.

#4 Updated by Jeff Miller over 9 years ago

I did notice that ref frame difference after more experimentation, sucks that that is the problem and hat a simple level change does not work. If its not an issue that can be fixed or a limitation of the PS3 that is fine, an error message would be nice though. This program is amazing and it just sucks half my HD shows don't play because of this.

Jérôme S. wrote:

You should by a PC or claim Sony for a more powerfull PS3.
I dont know if Andreas could do something about that.

I have a good gaming computer, but I would rather watch movies on my 60" TV through the PS3...as would most people I think.

#5 Updated by Jérôme S. over 9 years ago

I did mean a gaming computer, but a HTPC more powerfull than the PS3 at decoding HD video. Some can be attached at the back of TVs.
Like Xbox at is time, PS3 will show some limit to play HD video, even if it does a pretty good job with most of those for now.

#6 Updated by Girish Patel over 9 years ago

Jeff Miller wrote:

I did notice that ref frame difference after more experimentation, sucks that that is the problem and hat a simple level change does not work.

I've done a lot of experimentation too and a level change does work. But the problem is that it takes forever to re-encode a video file if the original has a too high ReFrame number.

It's usually mp4 4.1 with ReFrame of 4 that give problems but the work around is the PS3 will play it fine. Where as mkv files Showtime is the only app that will play them. So its either re-encode or just wait until something is sorted.

#7 Updated by Baye Baye over 9 years ago

Can't you just turn the level down with TSMUXERGUI?

#8 Updated by Jeff Miller over 9 years ago

Changing the level does not affect anything, because showtime will not play a file if the ref frame is too high, no matter what the level states. Any of the programs that just modify the level will NOT work. The only way to get these files to play is to re-encode them with a lower ref frame. I have found a program (http://www.videohelp.com/tools/uncropMKV) which does this very good and does not take too long. Just don't choose any of the crop/resolution changes and it will automatically set the ref frames to 3 with a 4.1 level. You can also queue a bunch up and let it go over night.

#9 Updated by Andreas Smas over 9 years ago

The SPU accelerated h264 decoder is only capable of decoding content up to level 4.2.

The level in h264 indicates stuff like resolution, frame-rate, max # of refframes, etc, see the wikipedia article

Now, some h264 decoders just set level 5.0 per default without actually using that many reference frames. That's why Showtime tricks the cell decoder by saying that the content is 4.2 (and when doing so also displays a warning).

So if you use some program that just changes this value without actually re-encoding the content you are definitely on thin ice. It's like trying to translate a book by just changing the language printed on the book cover :-) It will certainly not translate the book and would only confuse people even more.

Could the PS3 theoretically handle h264 level 5.0?
- I think so. The current implementation use 4 SPUs when decoding at level 4.2. That leaves two more left.

Is it an insane amount of work?
- Yes

Sony probably didn't care about level 5.0 as bluray content never exceeds level 4.2

#10 Updated by Girish Patel over 9 years ago

Could the PS3 theoretically handle h264 level 5.0?

I just to play an mp4 level 5.1 on the PS3. The video looked as though it was on fast forward and there was no audio.
Tried it through Showtime and it froze on opening and continued playing the audio.

#11 Updated by Girish Patel over 9 years ago

Girish Patel wrote:

Could the PS3 theoretically handle h264 level 5.0?

I just got to play an mp4 level 5.1 on the PS3. The video looked as though it was on fast forward and there was no audio.
Tried it through Showtime and it froze on opening and continued playing the audio.

Mkv'd the file with Profile 5.1 ReFrame 8. Showtime played it fine with the 4.2 message.

#12 Updated by Jeff Miller over 9 years ago

The resolution is another key factor. You are most likely playing a non HD video so it can handle a higher ref frame

#13 Updated by Andreas Smas over 9 years ago

  • Target version set to 3.4

#14 Updated by Andreas Smas over 9 years ago

  • Category set to Video playback

#15 Updated by Andreas Smas over 9 years ago

  • Status changed from New to Accepted

#16 Updated by Andreas Smas over 9 years ago

  • Status changed from Accepted to Rejected

5.1 content is not supported

Also available in: Atom PDF