Bug #719

Subtitles in mkv file are still on even though in settings they are off

Added by Girish Patel over 9 years ago. Updated over 9 years ago.

Status:FixedStart date:09/22/2011
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

100%

Category:Subtitles
Target version:3.4
Found in version:3.3.40 Platform:PS3

Description

I've just noticed in some mkv files that the subtitles keep coming on even though I've turned them off in the settings.

I think this is what quit the video playback in 3.3.37.

I played one mkv file in 3.2 and subtitles stayed off.
3.3.37 same file quit back to video list as soon as subtitles came on.
3.3.40 same file showed subtitles even though settings were off. Had to turn off subtitles in the pop up menu.

mkv_subtitle.jpg (219 KB) Girish Patel, 09/23/2011 01:06 PM

Associated revisions

Revision 73958cbc
Added by Andreas Smas over 9 years ago

Adjust threshold for automatic subtitle selection

Regression due to honoring the DEFAULT subtitle flag in libavformat

Fixes #719

Change included in version 3.3.52

History

#1 Updated by Girish Patel over 9 years ago

Just seen that next to the subtitle icon when the video starts to play it says 'text'.

#2 Updated by Jérôme S. over 9 years ago

check that your sub is not flaged as "forced" in the mkv.

#3 Updated by Girish Patel over 9 years ago

I have just checked and the subtitles are not set as 'forced'. They are set to default also.

Screenshot attached of the details from the file.

#4 Updated by Andreas Smas over 9 years ago

  • Status changed from New to Accepted

I think I know what the problem is. It's a bug that crept in when added support for the default tag.

#5 Updated by Andreas Smas over 9 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100

#6 Updated by Andreas Smas over 9 years ago

  • Target version set to 3.4

Also available in: Atom PDF