Bug #456

when fast forward movie I get some hitch

Added by Damir Hasic almost 10 years ago. Updated almost 10 years ago.

Status:FixedStart date:04/19/2011
Priority:NormalDue date:
Assignee:Damir Hasic% Done:

0%

Category:-
Target version:3.0
Found in version: Platform:

Description

I don't know is it only in new version because I didn't notice before. So when I fast forward movie I get some hitch in movie. Only way to get smooth playback is to play from begining without any fast forwarding.

History

#1 Updated by Minh Le almost 10 years ago

Damir Hasic wrote:

I don't know is it only in new version because I didn't notice before. So when I fast forward movie I get some hitch in movie. Only way to get smooth playback is to play from begining without any fast forwarding.

I thought I was the only one. Well, it's happening with MKV, 720x480 anime. No lag what so ever, so it's great! All I know is that if I'm going to watch 720p MP4/MKV, than I'll be using PS3 Media Server. Anyway, back to the subject, I get "hitched" as well, where the video frame will bounce back to a different frame than bounce back to the frame it was at and continues the movie. The problem happens really fast, but it happens constantly after fast forwarding. Also, it gets rid of the subtitle, but it will go back to normal. The only problem is the "hitching"

#2 Updated by buzhidao buzhidao almost 10 years ago

Damir Hasic wrote:

I don't know is it only in new version because I didn't notice before. So when I fast forward movie I get some hitch in movie. Only way to get smooth playback is to play from begining without any fast forwarding.

Andreas fix it in f6110669 2011/4/18 21:39:25 ps3: Fix seeking bugs when playing with cell acceleration

#3 Updated by Damir Hasic almost 10 years ago

I just try old version of Showtime and there is no hitching issue, so this is bug only in new version.

#4 Updated by Andreas Smas almost 10 years ago

  • Status changed from New to Need feedback
  • Assignee changed from Andreas Smas to Damir Hasic

Attach sample file please

#5 Updated by Damir Hasic almost 10 years ago

I get this hitching in every mkv movie I tried, but here is one sample. So try fast forwarding about 2-3 minutes and then look for hiching. It looks just like in these threadd sample https://www.lonelycoder.com/redmine/issues/460

#6 Updated by Andreas Smas almost 10 years ago

  • Status changed from Need feedback to Accepted

#7 Updated by Andreas Smas almost 10 years ago

I think this only happens IF you actually seek in the file, right?

#8 Updated by shinta himura almost 10 years ago

Hi, maybe i can answer for him ^^
yes, it actually happens to me only when i seek in the file.
plus, once i do it, i can't "pause" anymore the video. (the sound shutters, and the video continues)
Thanks a lot for your amazing work!

#9 Updated by shinta himura almost 10 years ago

As Damir Hasic said, this is a new issue as it didnt happen with your last release ;)

#10 Updated by Damir Hasic almost 10 years ago

Yes only happens when seek.

#11 Updated by Andreas Smas almost 10 years ago

Ok, i'm not able to flush the h264 decoder correctly so some frames are "stuck" in there and replayed over and over again.

I'm trying to figure out how to do that but because i don't have any documentation it's a bit tricky to understand how it is supposed to work...

#12 Updated by Damir Hasic almost 10 years ago

perhaps has to do something with support for level 5.0 and 5.1, which you have added in newest version? And if you could do that by pressing the FF button to skip 1-2 minute film. It might then be all right and no hitching? We do this seeking because we try to go back to the film, where we stopped it. Is there any chance that the program remembers exactly where we left off so that return to that time?

#13 Updated by Andreas Smas almost 10 years ago

  • Status changed from Accepted to Fixed

Fixed in 58346e32

#14 Updated by Damir Hasic almost 10 years ago

Thanks! So when you gonna put that in new PKG?

#15 Updated by Damir Hasic almost 10 years ago

Can anyone add this in last pkg with Windows 1250 support? Thanks!

#17 Updated by Andreas Smas almost 10 years ago

  • Target version changed from 2.99 to 3.0

Also available in: Atom PDF