Bug #443

UI inconsistencies over slow media bookmarks

Added by Mateusz Mojsiejuk almost 10 years ago. Updated almost 10 years ago.

Status:FixedStart date:04/17/2011
Priority:LowDue date:
Assignee:Andreas Smas% Done:

0%

Category:Video playback
Target version:3.0
Found in version: Platform:

Description

When starting playback of a file over http, there can be of course be a delay before it actually starts.

The UI representation of this waiting time isn't obvious.

When it happened to me i didn't realize i had actually pressed the play file button since nothing happened.
I then pressed "play" on another file.

this resulted in playback of the first file that suddenly got stopped so to play back second file i had pressed.

History

#1 Updated by Andreas Smas almost 10 years ago

  • Category changed from Bookmarks to Video playback
  • Status changed from New to Accepted
  • Assignee set to Andreas Smas

I agree that this is kinda bad. It's because Showtime needs to probe the file before it can know what it should do with it. This can be slow. So there are few things that can be used to mitigate this.

  • A URL -> filetype cache
  • Don't probe some common file endings, ie. assume that .mkv and .avi, etc is movies.

#2 Updated by Andreas Smas almost 10 years ago

  • Status changed from Accepted to Fixed
  • Target version set to 2.99

I actually fixed it, but differently in 8ce6a912

#3 Updated by Andreas Smas almost 10 years ago

  • Target version changed from 2.99 to 3.0

Also available in: Atom PDF