Bug #3392

Hiccups when watching certain mkv's on Sony Bravia (Android)

Added by Swiss Chris 9 months ago. Updated 4 months ago.

Status:NewStart date:08/25/2018
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:Video playback
Target version:-
Found in version:5.0.546 Platform:Android

Description

i often watch dubbed movies, where the audio and video obviously come from different sources. some of these have hiccups every few seconds (looks like lost frames or a quick jump in the playback). they play fine with movian on PS3 and on other platforms (tested MacOS and iOS) and even on an Android phone.

it turns out that the movies with the hiccups have inconsistent frame rates (can be verified with mediainfo):

Frame rate mode : Constant
Frame rate : 25.000 FPS
Original frame rate : 23.976 (24000/1001) FPS -> this seems to be the issue. Movian plays that file @ 25 FPS

i think this is caused by the different sources of the video and audio material.

and a working movie looks like this:

Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
No Original frame rate - runs @ 23.976 FPS

or another working movie:

Frame rate mode : Constant
Frame rate : 25.000 FPS
No Original frame rate - runs @ 25 FPS

i can fix the frame rate with MKVToolNix (remuxing to 24000/1001p) and then the hiccups are gone - BUT of course the audio doesnt match anymore. i can reencode the audio and then use it with the remuxed mkv to make it play fine on my TV - which is obviously not very comfortable and not needed on other platforms.

any idea whats causing Movian to play these files with hiccups on the TV?

tvp-ballers-s04e04-1080p_hiccups.mkv (64.7 MB) Swiss Chris, 01/28/2019 01:31 PM

Video_1 2019-01-28_13-35-06.mov (26.2 MB) Swiss Chris, 01/28/2019 01:37 PM

History

#1 Updated by Rob Koni 6 months ago

You might have to attach example files to verify this.

#2 Updated by Swiss Chris 4 months ago

here is an example file. this one runs fine on every other platform (PS3, tvOS, MacOS) and even on an Android 7.0 Phone.

#3 Updated by Swiss Chris 4 months ago

and here is a capture of it (recorded with my phone) running on my Android TV. you clearly can see that it skips frames every few seconds.

#4 Updated by Swiss Chris 4 months ago

btw: i think this is the same issue: https://forum.kodi.tv/showthread.php?tid=310393&page=10

those files are not properly encoded it seems, but they work just fine on any other platform - only the Sony Bravia has issues with it.

Also available in: Atom PDF