Bug #3331

Plugin and Movian autoupdate doesn't happen if network interface comes up with a delay (regression)

Added by Leonid Protasov almost 3 years ago. Updated over 2 years ago.

Status:AcceptedStart date:12/21/2017
Priority:NormalDue date:
Assignee:Leonid Protasov% Done:

0%

Category:General
Target version:5.2
Found in version:5.0.494 Platform:RPi

Description

00:00:00.963: CONNMAN         [DEBUG]:Technologies: ([(objectpath '/net/connman/technology/ethernet', {'Name': <'Wired'>, 'Type': <'ethernet'>, 'Powered': <true>, 'Connected': <false>, 'Tethering': <false>})],)
00:00:04.084: plugins         [DEBUG]:Loading repo from https://movian.tv/api/plugins/plugins-v1.json
00:00:04.084: HTTP            [INFO ]:Connect to movian.tv:443
00:00:04.122: plugins         [ERROR]:Unable to load repo https://movian.tv/api/plugins/plugins-v1.json -- Unable to resolve movian.tv -- A temporary error occurred on an authoritative name server
00:00:04.122: plugins         [DEBUG]:Failed to update repo, retrying in 1 seconds
00:00:04.122: plugins         [DEBUG]:Loading repo from https://movian.tv/api/plugins/plugins-v1.json
00:00:04.122: HTTP            [INFO ]:Connect to movian.tv:443
00:00:04.124: plugins         [ERROR]:Unable to load repo https://movian.tv/api/plugins/plugins-v1.json -- Unable to resolve movian.tv -- A temporary error occurred on an authoritative name server
00:00:04.124: plugins         [DEBUG]:Failed to update repo, retrying in 2 seconds
00:00:06.124: plugins         [DEBUG]:Loading repo from https://movian.tv/api/plugins/plugins-v1.json
00:00:06.124: HTTP            [INFO ]:Connect to movian.tv:443
00:00:06.126: plugins         [ERROR]:Unable to load repo https://movian.tv/api/plugins/plugins-v1.json -- Unable to resolve movian.tv -- A temporary error occurred on an authoritative name server
00:00:06.126: plugins         [DEBUG]:Failed to update repo, retrying in 3 seconds
00:00:06.551: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.552: CONNMAN         [DEBUG]:('State', <'ready'>)
00:00:06.552: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.552: CONNMAN         [DEBUG]:('Timeservers', <['85.159.1.142', '192.168.88.1', '0.pool.ntp.org', '1.pool.ntp.org', '2.pool.ntp.org', '3.pool.ntp.org']>)
00:00:06.677: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.677: CONNMAN         [DEBUG]:('Nameservers', <['8.8.8.8', '8.8.4.4']>)
00:00:06.677: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.678: CONNMAN         [DEBUG]:('Domains', <@as []>)
00:00:06.678: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.678: CONNMAN         [DEBUG]:('Proxy', <{'Method': <'direct'>}>)
00:00:06.678: CONNMAN         [DEBUG]:Manager-signal PropertyChanged from :1.1
00:00:06.678: CONNMAN         [DEBUG]:('State', <'ready'>)
00:00:06.714: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.714: CONNMAN         [DEBUG]:('IPv4', <{'Method': <'dhcp'>, 'Address': <'192.168.88.58'>, 'Netmask': <'255.255.255.0'>}>)
00:00:06.716: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.716: CONNMAN         [DEBUG]:('IPv4', <{'Method': <'dhcp'>, 'Address': <'192.168.88.58'>, 'Netmask': <'255.255.255.0'>, 'Gateway': <'192.168.88.1'>}>)
00:00:06.863: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.863: CONNMAN         [DEBUG]:('Timeservers', <['85.159.1.142', '192.168.88.1', '0.pool.ntp.org', '1.pool.ntp.org', '2.pool.ntp.org', '3.pool.ntp.org']>)
00:00:06.864: CONNMAN         [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb305810_cable PropertyChanged from :1.1
00:00:06.864: CONNMAN         [DEBUG]:('State', <'online'>)
00:00:06.864: CONNMAN         [DEBUG]:Manager-signal PropertyChanged from :1.1
00:00:06.864: CONNMAN         [DEBUG]:('State', <'online'>)
00:00:10.126: plugins         [DEBUG]:Loading repo from https://movian.tv/api/plugins/plugins-v1.json
00:00:10.127: HTTP            [INFO ]:Connect to movian.tv:443
00:00:10.598: GEO             [DEBUG]:Current country: UA
00:00:10.602: Upgrade         [DEBUG]:Checking upgrades for master-rpi
00:00:10.602: youtube         [DEBUG]:Region set to UA

By the log it looks like ok, but update of movian and plugins is not happening. After manual restart of movian (exit in right side menu) it finds the updates :(
That all somehow affects getting the time from NTP servers as it's happening too long...

History

#1 Updated by Leonid Protasov almost 3 years ago

  • Subject changed from Plugin autoupdate and autoupdate is broken on RPI (regression) to Plugin and Movian autoupdate are broken on RPI (regression)

#2 Updated by Leonid Protasov over 2 years ago

  • Subject changed from Plugin and Movian autoupdate are broken on RPI (regression) to Plugin and Movian autoupdate fails if network interface comes up with a delay (regression)

#3 Updated by Leonid Protasov over 2 years ago

  • Subject changed from Plugin and Movian autoupdate fails if network interface comes up with a delay (regression) to Plugin and Movian autoupdate doesn't happen if network interface comes up with a delay (regression)

#4 Updated by Leonid Protasov over 2 years ago

  • Status changed from New to Need feedback

#5 Updated by Leonid Protasov over 2 years ago

  • Status changed from Need feedback to Accepted
  • Assignee changed from Andreas Smas to Leonid Protasov

#6 Updated by Leonid Protasov over 2 years ago

  • Priority changed from Immediate to Normal

Also available in: Atom PDF