Bug #3327

RPi: DVD menus don't work, DVDs are not detected, "dvd:" starts a search

Added by Gregor Hoffleit almost 3 years ago. Updated almost 3 years ago.

Status:NewStart date:12/15/2017
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:DVD
Target version:-
Found in version:5.0.494 Platform:RPi

Description

On the Raspberry, DVDs are not shown in the home screen. Also, DVD menus don't work. Entering "dvd:" starts

On Linux, when I insert a DVD, Movian shows a DVD icon on the home screen. When I open the icon, the DVD menu is shown. Entering "dvd://dev/sr0" or "/dev/sr0" in the navigation bar has the same effect.

On the RPi, when I insert a DVD into an external drive, nothing happens.

When I enter "/dev/sr0", the Raspberry opens a DVD, but DVD menus won't work. I'm able to start a chapter by pressing play, but no navigation is possible.

When I enter "dvd://dev/sr0" on the Raspberry, Movian starts a search, i.e. it fails to handle the "dvd:" prefix.

rpi.log - RPi debug log (36.1 KB) Gregor Hoffleit, 12/15/2017 10:11 PM

linux.log - Linux debug log (DVD menu works) (17.4 KB) Gregor Hoffleit, 12/15/2017 10:11 PM

History

#1 Updated by Gregor Hoffleit almost 3 years ago

#2 Updated by Rural Hunter almost 3 years ago

This might be duplicate with #2064.

#3 Updated by Gregor Hoffleit almost 3 years ago

Thanks for the hint!

Looking down the queue, this issue seems to be related to #1986 as well ("DVD menu is not shown on RPi"), which was appearently fixed with this Revision f9313eba four years ago.

At least parts of this commit later on were touched (if not reverted) by Revision 8e836f5a, which was intended to fix #2030 (Wrong aspect ratio on WMV9 (rpi)).

This might be a regression then.

Also available in: Atom PDF