Bug #3166

PS3 - Movian crashes PS3 when playing torrent

Added by seb cas almost 5 years ago. Updated almost 5 years ago.

Status:NewStart date:06/04/2016
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:Plugins
Target version:-
Found in version:5.0.6.161.g70d684 Platform:PS3

Description

Torentz plugin, after searching and selecting file to play it starts downloading the file and just before it starts playing the PS3 freezes completely.
Tried uninstalling and reinstalling the plugin, clearing torrents cache, but nothing helps.
Log attached

movian-1.log (10.6 KB) seb cas, 06/04/2016 07:40 PM


Related issues

Related to Bug #2778: Error: pipe problems. No buffer space available. Torrents Fixed 08/28/2015
Related to Bug #2754: TCP [ERROR]:Pipe problems with torrents Rejected 07/10/2015
Duplicated by Bug #3244: Pirate bay freezing New 12/13/2016

History

#1 Updated by Dean Kasabow almost 5 years ago

I tested versions back to 5.0.5 and all have the same problem. Movian either crashes to XMB or something "locks" and it is impossible to play anything else after you try to open a .torrent file.

Also after version .133 the jpegs are not decoded properly. I'm using this background image on RPi2/3 and PS3 and it shows only stripes on the PS3 (I tested 3 other images with the same result): http://deanbg.com/public/rpi/bg3.jpg

#2 Updated by Andreas Smas almost 5 years ago

So .. when i tested this URL it works perfectly.

This bug has been around for a long time and i'm not able to figure it out.

What kind of internet connections do you guys have? How much upstream/downstream bandwidth?

#3 Updated by Andreas Smas almost 5 years ago

  • Related to Bug #2778: Error: pipe problems. No buffer space available. Torrents added

#4 Updated by Andreas Smas almost 5 years ago

  • Related to Bug #2754: TCP [ERROR]:Pipe problems with torrents added

#5 Updated by Dean Kasabow almost 5 years ago

Andreas Smas wrote:

What kind of internet connections do you guys have? How much upstream/downstream bandwidth?

My RPi3, RPi2 and the PS3 are on the same network and I have 30MBit/s download and 20MBit/s upload speed.

I noticed on the PS3 that once I open the .torrent file I get 30-40 lines in the log (ASYNCIO) but can't remember the exact message (all peer were listed with IP:PORT + some text).

#6 Updated by seb cas almost 5 years ago

I've got 20Mbit/s download and 2Mbit/s upload.
I don't remember exactly when this started happened, but I'm pretty sure it was after the upgrade that changed the looks of the entire interface(don't remember which version number was). Before that it worked perfectly.

#7 Updated by Dean Kasabow almost 5 years ago

I solved all the issues by completely removing the PS3 toolchain and recompiling it from scratch with your Autobuild.sh -t ps3 script. Now the jpeg shows fine and torrents work in 99% of the time.

#8 Updated by Andreas Smas over 4 years ago

  • Duplicated by Bug #3244: Pirate bay freezing added

Also available in: Atom PDF