Bug #2571

Movian won't load subs from UPnP share ("no_fs_scan": 1)

Added by ananias 47 over 5 years ago. Updated over 5 years ago.

Status:RejectedStart date:03/03/2015
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:Subtitles
Target version:4.10
Found in version:4.9.298 Platform:PS3

Description

hi when i use my build in twonky server of my wd nas on st the srt works well but when i use twonky windows version on my android phone the srt works well but on st i cant see the subs

why????

thnx

showtime-0.log - windows twonky (19.9 KB) ananias 47, 03/04/2015 05:45 PM

showtime-0 (1).log - nas twonky (26.2 KB) ananias 47, 03/04/2015 05:45 PM

History

#1 Updated by Tiago windcrusher over 5 years ago

ananias 47 wrote:

hi when i use my build in twonky server of my wd nas on st the srt works well but when i use twonky windows version on my android phone the srt works well but on st i cant see the subs

why????

thnx

I have wd my cloud and I prefer use with smb share. (try yourself)

#2 Updated by Leonid Protasov over 5 years ago

4.8.11 Showtime is history. Try Movian on Bleeding Edge. If the problem exist - please report with the log.

#3 Updated by ananias 47 over 5 years ago

still the same fter update

here the logs

again i would like to say that both twonky on nas and windows are working on android phone with srt like a charm so the problem is on movian

thnx again

#4 Updated by ananias 47 over 5 years ago

is there any news my friend???

#5 Updated by Leonid Protasov over 5 years ago

  • Subject changed from showtime and twonky server to Movian won't load subs from UPnP share ("no_fs_scan": 1)
  • Target version set to 4.10
  • Found in version changed from 4.8.11 to 4.9.298

In the log I see:

00:00:51.938: vp              [DEBUG]:Playing 'videoparams:{"canonicalUrl": "http://192.168.1.49:9000/disk/DLNA-PNAVI-OP01-FLAGS01700000/O0$3$27I269.avi","no_fs_scan": 1,"title": "Banshee.S01E01.HDTV.XviD-AFG","sources": [{"url": "http://192.168.1.49:9000/disk/DLNA-PNAVI-OP01-FLAGS01700000/O0$3$27I269.avi","mimetype": "video/avi"}],"subtitles": []}', primary, resume:ask user (overridden)

Looks like "no_fs_scan": 1 is the problem...

#6 Updated by Andreas Smas over 5 years ago

  • Status changed from New to Need feedback

no_fs_scan is just for not trying to do a directory listing to find the subs.

The upnp code should try to look for subtitles using a HTTP request.

If you could recapture the logfiles again but first go to "settings:dev" (enter that in the search bar on the home screen) and turn on "HTTP debugging", maybe we can find out what's going no.

Thanks,
Andreas

#7 Updated by Andreas Smas over 5 years ago

  • Status changed from Need feedback to Rejected

No feedback.

Also available in: Atom PDF