Bug #2546

Youtube URIError

Added by chris file over 5 years ago. Updated over 5 years ago.

Status:FixedStart date:02/07/2015
Priority:NormalDue date:
Assignee:Leonid Protasov% Done:

100%

Category:Plugins
Target version:-
Found in version:3.1.3 Platform:PS3

Description

If additional info page is enabled, on the YouTube plugin, then when you start the video, showtime is freezing.

Associated revisions

Revision 5b309376
Added by Andreas Smas over 5 years ago

text: Need to clamp bounding box to max_width or margin might explode

This causes too big textures to be created

refs #2546

Change included in version 4.9.149

History

#1 Updated by Leonid Protasov over 5 years ago

  • Assignee changed from Andreas Smas to Leonid Protasov

#2 Updated by Benjamin Hojnik over 5 years ago

Any ideas why can i only play youtube videos at 720p max (i've set 1080p in settings) ?

This is on PS3 btw..

#3 Updated by Leonid Protasov over 5 years ago

Benjamin Hojnik wrote:

Any ideas why can i only play youtube videos at 720p max (i've set 1080p in settings) ?

This is on PS3 btw..

It needs https://showtimemediacenter.com/issues/2217

#4 Updated by chris file over 5 years ago

Leonid Protasov wrote:

Can you attach the log? https://showtimemediacenter.com/projects/showtime/wiki/Logging

Here the log file

http://sprunge.us/HOMP

#5 Updated by Leonid Protasov over 5 years ago

  • Subject changed from YouTube plugin freezes showtime if additional info is enabled to URIError (All platforms)
  • Status changed from New to Accepted
  • Assignee changed from Leonid Protasov to Andreas Smas
  • Priority changed from Normal to High
  • Target version set to 4.10
  • Found in version changed from 4.9.??? to 4.9.142

To reproduce just play:

youtube:video:advanced:E7ug3CzCMig

On error ST has problem displaying error page as well.

#6 Updated by Leonid Protasov over 5 years ago

  • Category changed from Plugins to Ecmascript & Duktape

#7 Updated by Andreas Smas over 5 years ago

  • Status changed from Accepted to Need feedback
  • Priority changed from High to Normal

I've no idea what's going on here except i think that the URI decoder bails out due to invalid UTF-8 sequences.

Just looking at the line:

(unescape(unescape(decodeURIComponent(title)))

makes my head explode. 3 x escaping? what? why?

#8 Updated by Andreas Smas over 5 years ago

Then there is a problem with font rendering that causes the error message to disappear (on OSX it actually crashes)

#9 Updated by Leonid Protasov over 5 years ago

  • Subject changed from URIError (All platforms) to Youtube URIError
  • Category changed from Ecmascript & Duktape to Plugins
  • Status changed from Need feedback to Fixed
  • Assignee changed from Andreas Smas to Leonid Protasov
  • Target version deleted (4.10)
  • % Done changed from 0 to 100
  • Found in version changed from 4.9.142 to 3.1.3

Fixed in 3.1.4.

Also available in: Atom PDF