Bug #2538

SMB client can't open some PC (All platforms)

Added by Leonid Protasov over 5 years ago. Updated over 5 years ago.

Status:RejectedStart date:02/04/2015
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:General
Target version:4.10
Found in version:4.9.129 Platform:Linux

Description

BIG is 192.168.0.93 (Win7)
RENI is 192.168.0.104 (Win7)
UBUNTU is 192.168.0.95 (Ubuntu)

ST can open all beside BIG.

http://sprunge.us/eciG

Associated revisions

Revision ffa1c8b8
Added by Andreas Smas over 5 years ago

smb: Query for 0x20 (Fileserver) when trying to resolve names over NetBIOS

refs #2538

Change included in version 4.9.135

History

#1 Updated by Andreas Smas over 5 years ago

  • Status changed from New to Need feedback

I can't reproduce the issue but i checked in a fix that might help. Please test it.

#2 Updated by Leonid Protasov over 5 years ago

Andreas Ă–man wrote:

I can't reproduce the issue but i checked in a fix that might help. Please test it.

No still no luck:

SYSTEM          [INFO ]: Showtime 4.9.139.g84aa2 starting. 1 CPU cores. Systemtype:Linux/x86_64 OS:Ubuntu 12.04.5 LTS
core            [DEBUG]: Loading resources from ./
blobcache       [DEBUG]: Cache magic 0x62630207 6272 items
blobcache       [INFO ]: Initialized: 6272 items consuming 180.60 MB (out of maximum 785.28 MB) on disk in /root/.cache/showtime/bc2
DB              [DEBUG]: Opened database /root/.hts/showtime/kvstore/kvstore.db pages: free=0 total=1694
DB              [DEBUG]: kvstore: At current version 2
DB              [DEBUG]: Opened database /root/.hts/showtime/metadb/meta.db pages: free=0 total=284
DB              [DEBUG]: metadb: At current version 17
libav           [INFO ]: Lavf56.1.0, Lavc56.1.0, Lavu54.3.0
Freetype        [DEBUG]: Loaded font family='liberation sans' fullname='liberation sans regular' style='Regular' from .//resources/fonts/liberation/LiberationSans-Regular.ttf domain:0
playqueue       [DEBUG]: Shuffle set to off
playqueue       [DEBUG]: Repeat set to off
playqueue       [DEBUG]: Nothing on queue, waiting
SMB             [DEBUG]: Connected to 192.168.0.93:445
SMB             [DEBUG]: 192.168.0.93:445 Protocol negotiated
SMB             [DEBUG]: SETUP guest:<unset>:WORKGROUP
SMB             [DEBUG]: SETUP errorcode=0xc000006d
SMB             [DEBUG]: Disconnecting from 192.168.0.93:445
SMB             [DEBUG]: Connected to 192.168.0.93:445
SMB             [DEBUG]: 192.168.0.93:445 Protocol negotiated
SMB             [DEBUG]: SETUP lenya:<hidden>:WORKGROUP
SMB             [DEBUG]: SETUP errorcode=0x00000000
SMB             [DEBUG]: Logged in as UID:2048 guest=no os='Windows 7 Ultimate 7601 Service Pack 1' lanman='Windows 7 Ultimate 6.1' PD='WORKGROUP'
SMB             [DEBUG]: 192.168.0.93:445 Session setup
SMB             [DEBUG]: 192.168.0.93:445 smb_tree_connect_andX sent mid=0 on thread 7ffdbb7fe700
SMB             [DEBUG]: 192.168.0.93:445 Read thread running 7ffdb97fa700
SMB             [DEBUG]: 192.168.0.93:445 Got response for mid=0 (err:0x00000000 len:54)
SMB             [DEBUG]: Tree connect errorcode:0x00000000 (c$)
SMB             [DEBUG]: 192.168.0.93:445 cifs_stat sent mid=1 on thread 7ffdbb7fe700
SMB             [DEBUG]: 192.168.0.93:445 Got response for mid=1 (err:0x00000000 len:100, TRANS2)
SMB             [DEBUG]: trans2 segment: total=40 param_count=2 data_count=40 poff=56
PA              [DEBUG]: Headerversion: 1.1.0, library: 1.1.0
plugins         [INFO ]: Loaded dev plugin file:///root/showtime-plugins/tv
i18n            [INFO ]: Unloading language definition
i18n            [DEBUG]: Default charset is auto
SYSTEM          [DEBUG]: Hashed device ID: 026471cdff337be92b8175b7c7c2c122
TCP             [INFO ]: http-server: Listening on port 42000
AVAHI           [DEBUG]: Client state change 2
SSDP            [DEBUG]: Running
UDP             [INFO ]: nmb: Listening on port 38131
UDP             [INFO ]: bittorrent udp tracker: Listening on port 50464
navigator       [INFO ]: Opening page:home
SMB             [DEBUG]: Connected to 192.168.0.95:445
SMB             [DEBUG]: 192.168.0.95:445 Protocol negotiated
SMB             [DEBUG]: SETUP anonymous
SMB             [DEBUG]: SETUP errorcode=0x00000000
SMB             [DEBUG]: Logged in as UID:100 guest=yes os='Unix' lanman='Samba 3.6.3' PD='WORKGROUP'
SMB             [DEBUG]: 192.168.0.95:445 Session setup
SMB             [DEBUG]: 192.168.0.95:445 smb_tree_connect_andX sent mid=0 on thread 7ffdacff9700
SMB             [DEBUG]: 192.168.0.95:445 Read thread running 7ffd9bfff700
SMB             [DEBUG]: 192.168.0.95:445 Got response for mid=0 (err:0x00000000 len:48)
SMB             [DEBUG]: Tree connect errorcode:0x00000000 (IPC$)
SMB             [DEBUG]: 192.168.0.95:445 smb_NetServerEnum2 sent mid=1 on thread 7ffdacff9700
SMB             [DEBUG]: 192.168.0.95:445 Got response for mid=1 (err:0x00000000 len:147)
SMB             [DEBUG]: Found server BIG
SMB             [DEBUG]: Found server UBUNTU
SMB             [DEBUG]: Disconnecting from 192.168.0.95:445
spotify         [DEBUG]: Loaded from /root/showtime/build.linux/libspotify-12.1.51-Linux-x86_64-release/lib/libspotify.so.12
Spotify         [INFO ]: Using library version 12.1.51.g86c92b43 Release Linux-x86_64 
plugins         [DEBUG]: Loading repo from http://showtime.lonelycoder.com/plugins/plugins-v1.json
GLW             [DEBUG]: GLX_SGI_swap_control extension is present
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
VDPAU           [DEBUG]: Unable to create VDPAU device
VDPAU           [DEBUG]: Unable to create VDPAU device
GLW             [DEBUG]: Window manager (Compiz) detected, can fullscreen
GLW             [DEBUG]: 16 texture image units available
GLW             [INFO ]: OpenGL Renderer: 'Gallium 0.4 on SVGA3D; build: RELEASE;  ' by 'VMware, Inc.'
GLW             [INFO ]: OpenGL driver does not provide adequate vertical sync capabilities. Using soft timers
GLW             [DEBUG]: UI size scale changed to 19 (user adjustment: 6)
Freetype        [DEBUG]: Loaded font family='arial unicode ms' fullname='arial unicode ms regular' style='Regular' from file:///root/.hts/showtime/installedfonts/ARIALUNI.TTF domain:11
navigator       [INFO ]: Opening page:discovered
navigator       [INFO ]: Opening smb://BIG
SMB             [DEBUG]: Unable to connect to BIG:445 - Unknown host
SMB             [DEBUG]: Unable to connect to BIG:445 - Unknown host
SMB             [DEBUG]: Connected to 192.168.0.95:445
SMB             [DEBUG]: 192.168.0.95:445 Protocol negotiated
SMB             [DEBUG]: SETUP anonymous
SMB             [DEBUG]: SETUP errorcode=0x00000000
SMB             [DEBUG]: Logged in as UID:100 guest=yes os='Unix' lanman='Samba 3.6.3' PD='WORKGROUP'
SMB             [DEBUG]: 192.168.0.95:445 Session setup
SMB             [DEBUG]: 192.168.0.95:445 smb_tree_connect_andX sent mid=0 on thread 7ffdacff9700
SMB             [DEBUG]: 192.168.0.95:445 Read thread running 7ffd8c6ec700
SMB             [DEBUG]: 192.168.0.95:445 Got response for mid=0 (err:0x00000000 len:48)
SMB             [DEBUG]: Tree connect errorcode:0x00000000 (IPC$)
SMB             [DEBUG]: 192.168.0.95:445 smb_NetServerEnum2 sent mid=1 on thread 7ffdacff9700
SMB             [DEBUG]: 192.168.0.95:445 Got response for mid=1 (err:0x00000000 len:147)
SMB             [DEBUG]: Found server BIG
SMB             [DEBUG]: Found server UBUNTU
SMB             [DEBUG]: Disconnecting from 192.168.0.95:445

#3 Updated by Leonid Protasov over 5 years ago

Maybe I that's because BIG is in OFFICE group while ST tries to log in as WORKGROUP? Or maybe there is race as 192.168.0.93 is found before nmb: Listening on port?

[email protected]:~/showtime# smbtree
Enter root's password: 
WORKGROUP
    \\UBUNTU                 ubuntu server (Samba, Ubuntu)
        \\UBUNTU\Downloads          
        \\UBUNTU\Samsung_SCX-4725_Series_PCL6_(_1):2    Samsung SCX-4725 Series PCL6 ( 1)
        \\UBUNTU\__OneNote_2013:1    OneNote 2013
        \\UBUNTU\__OneNote_2010:1    OneNote 2013
        \\UBUNTU\Samsung_SCX-4725_Series_PCL6:3    Samsung SCX-4725 Series PCL6
        \\UBUNTU\Snagit_12:6        Snagit 12
        \\UBUNTU\Fax:5              Fax
        \\UBUNTU\Microsoft_XPS_Document_Writer:4    Microsoft XPS Document Writer
        \\UBUNTU\print$             Printer Drivers
        \\UBUNTU\IPC$               IPC Service (ubuntu server (Samba, Ubuntu))
    \\BIG                    
OFFICE

#4 Updated by Leonid Protasov over 5 years ago

Leonid Protasov wrote:

Maybe I that's because BIG is in OFFICE group while ST tries to log in as WORKGROUP?>

But looks like I incorrectly interpreted smbtree output as OFFICE is just empty and BIG belongs to WORKGROUP.

#5 Updated by Andreas Smas over 5 years ago

  • Status changed from Need feedback to Rejected

I've no idea how to fix this.

Also available in: Atom PDF