Bug #2537

UMS: No Fast-Forward

Added by Samir Habib over 5 years ago. Updated over 5 years ago.

Status:RejectedStart date:02/02/2015
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

0%

Category:UPnP & DLNA
Target version:4.10
Found in version:4.9 Bleeding Edge Platform:PS3

Description

Hi,
I've set up Universal Media Server this week, using the default configuration for wireless network. It works perfectly, all except that I can't fast-forward or jump to a specified time (This is possible when using the XMB, strangely enough, though).

When I'm at, let's say 5mn into the video, the time-bar just has marked : 5:00 ----- > 00:00, meaning Showtime can't detect the video's duration, and whenever I try to jump a minute or so forward, the video goes back to the beginning.
The UMS configuration is the default one (for wireless streaming), other than that, I don't know what information could be relevant.
It's the same behavior, whatever video I chose to play.

My question is : "Is there a way to fix this video duration problem? So i can navigate it properly using Showtime?".
Thank you.

VID_20150205_134122.3gp (22.9 MB) Samir Habib, 02/05/2015 02:04 PM

showtime-0.log (41.2 KB) Samir Habib, 02/05/2015 06:16 PM

History

#1 Updated by Leonid Protasov over 5 years ago

  • Category set to UPnP & DLNA
  • Status changed from New to Need feedback
  • Assignee set to Andreas Smas

Is this still reproducible on 4.9.134?

#2 Updated by Samir Habib over 5 years ago

Leonid Protasov wrote:

Is this still reproducible on 4.9.134?

I've made the upadte just now. And yes, the problem persists.
I've added a video, showing the problem, just in case.

#3 Updated by Leonid Protasov over 5 years ago

  • Target version set to 4.10

Log could be handy. Can you attach it? https://showtimemediacenter.com/projects/showtime/wiki/Logging
Log 0 is enough.

#4 Updated by Samir Habib over 5 years ago

Sure, here it is.

#5 Updated by Andreas Smas over 5 years ago

  • Status changed from Need feedback to Rejected

I think the problem here is that UMS remuxes the stream on the fly from mkv to mpeg, see

00:02:04.862: probe           [DEBUG]:http://192.168.1.10:5001/get/142/%5BCoalgirls%5D_Hyouka_01_%281280x720_Blu-Ray_FLAC%29_%5BE10E8818%5D.mkv: Probed as mpeg

If you play the stream from local PS3 HD or anything else i bet it works ok.

I think UMS remuxes when it detects an MAC address from PS3. It would be best if the authors of UMS could avoid remuxing the stream if it detect Showtime as user agent in HTTP requests.

Sorry, but I don't have time to install UMS and try to figure out a way to emulate the PS3 mpeg demuxer with all its quirks because to me that's just adding a workaround for a workaround in UMS.

Either contact the authors of UMS and ask them to avoid remuxing if HTTP user agent begins with Showtime, or just don't use UMS.

#6 Updated by Samir Habib over 5 years ago

The reason I use UMS in this case is because it's a 10bit video. Otherwise I just stream my video normally and it works perfectly well.
I've tried contacting them too. Not much luck so far ^^

Anyway, thanks for both your answers. Good night.

#7 Updated by Andreas Smas over 5 years ago

Ok, so in case of 10-bit video i guess you need to transcode it somewhere since the PS3 SPU h264 decoder can't do 10 bit :-(

Also available in: Atom PDF