Bug #2536

Play from beginning (item menu) is broken (regression) (Any platform)

Added by Ema Nymton over 5 years ago. Updated over 5 years ago.

Status:FixedStart date:02/02/2015
Priority:HighDue date:
Assignee:Andreas Smas% Done:

100%

Category:Video playback
Target version:4.10
Found in version:4.9.126 Platform:PS3

Description

Example with this video that I started playing last weekend: https://www.youtube.com/watch?v=bg2NYCOjHK4
Playback from the last position works fine but as soon as I seek in the video the image will go dark but sound will continue.
The console will then be unresponsive. Only solution is hard reset.

This behavior happened after upgrading to 4.9.126.g2f965

Also, play from the beginning doesn't work - it keeps on playing back from the last position. Seems to be related to the last

Nothing wrong in the logs as the console doesn't crash.

Associated revisions

Revision ed2e0780
Added by Andreas Smas over 5 years ago

Fix problem with restart/resume when selected from item menu

Page redirects caused that particular information to get lost

Fixes #2536

Change included in version 4.9.145

History

#1 Updated by Leonid Protasov over 5 years ago

  • Status changed from New to Need feedback
  • Target version set to 4.10

Is this reproducible on 4.9.134?

#2 Updated by Ema Nymton over 5 years ago

Fixed in 4.9.134 (no crash anymore) but the "Play from the beginning" option still doesn't work (it plays from the current resume point)

00:01:32.205: Video [DEBUG]:Starting playback of https://r1---sn-ipoxu-un5z.googlevideo.com/videoplayback?type=video/webm;+codecs&quality=medium&itag=43&expire=1423135793&mime=video%2Fwebm&pl=20&ratebypass=yes&source=youtube&dur=0.000&key=yt5&ipbits=0&id=o-AG2hwjoGYFTIsSdJ76k9mGcoHt3GR2w6bykGK6EN-o9K&sver=3&fexp=907263%2C919157%2C927622%2C930676%2C932113%2C933112%2C934960%2C936118%2C9405419%2C9406544%2C9406848%2C942627%2C943917%2C947225%2C948124%2C952302%2C952605%2C952612%2C952901%2C955301%2C957201%2C959701&signature=857CD28196B1646BF174BE864284F7A673C3FE84.554E1B6F6CB13D800CDCA4F17C78BD7B28331349&ip=114.36.20.62&requiressl=yes&initcwndbps=2322500&ms=au&mt=1423114166&mv=m&upn=JbHSGuLQ4-Q&sparams=dur%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Cmime%2Cmm%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cupn%2Cexpire&mm=31&fallback_host=tc.v22.cache2.googlevideo.com (matroska,webm)
00:01:32.206: Probe [DEBUG]: Stream #0: Video: vp8, yuv420p, 482x360
00:01:32.206: Probe [DEBUG]: Stream #1: Audio: vorbis, 44100 Hz, stereo, fltp
00:01:32.207: media [DEBUG]:Selecting track libav:1, best score 11
00:01:32.207: Subscanner [DEBUG]:Starting subtitle scan for 7 sur 7 SM le roi Hassan II interview par Anne Sinclair datant du 14 mai 1993 (imdbid:<unknown>) year:0 season:-1 episode:-1 duration:3276 opensubhash:2eacf9acbeed1bef
00:01:32.207: Media [DEBUG]:Selecting audio track libav:1
00:01:32.208: Video [DEBUG]: Stream #0: Video: vp8, yuv420p, 482x360
00:01:32.210: Video [DEBUG]: Stream #0: Codec created
00:01:32.211: Video [DEBUG]: Stream #1: Audio: vorbis, 44100 Hz, stereo, fltp
00:01:32.215: Video [DEBUG]: Stream #1: Codec created
00:01:32.224: VIDEO [DEBUG]:Attempting to resume from 615.87 seconds
00:01:32.225: Video [DEBUG]:seek restart position to 615.87 (615874000 - 0)
00:01:32.310: audio [DEBUG]:Codec changed to vorbis (0x15005)
00:01:32.314: AUDIO [DEBUG]:The state is 0
00:01:32.329: AUDIO [DEBUG]:PS3 audio port 0 opened (2 channels)
00:01:32.330: Audio [DEBUG]:Converting from [stereo 44100Hz fltp] to [stereo 48000Hz flt]

#3 Updated by Leonid Protasov over 5 years ago

  • Subject changed from Youtube plugin acting up when seeking in video after resuming to Play from beginning (item menu) is broken (regression) (Any platform)
  • Category changed from Plugins to Video playback
  • Status changed from Need feedback to Accepted
  • Priority changed from Normal to High

Reproducible in youtube plugin on any video. After regression ST plays always from resume point.

#4 Updated by Владимир Пилипчук over 5 years ago

  • Copied to Bug #2543: Play from beginning (item menu) is broken (regression) (Any platform) added

#5 Updated by Leonid Protasov over 5 years ago

  • Copied to deleted (Bug #2543: Play from beginning (item menu) is broken (regression) (Any platform))

#6 Updated by Andreas Smas over 5 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF