Bug #2434

ST segfaults on DELETE request completion

Added by Leonid Protasov over 6 years ago. Updated over 6 years ago.

Status:FixedStart date:12/30/2014
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

100%

Category:General
Target version:4.8
Found in version:4.7.585 Platform:Linux

Description

Reproducible on Youtube 3.0.3

HTTP            [DEBUG]: > DELETE /youtube/v3/subscriptions?id=bzZa8bZxwD6Rt0JnIlNJ66Rsop_mkxfzVw15YC5-rmw&key=AIzaSyCSDI9_w8ROa1UoE2CNIUdDQnUhNbp9XR4 HTTP/1.1
HTTP            [DEBUG]: > Authorization: Bearer ya29.7ABPObL6pudlyWFNRYe3JcO5RQWi7PakUef-ouhHzONkT5V7HZJO9CLEzkkoDe9k7CHTji5Ft-slDg
HTTP            [DEBUG]: > User-Agent: Showtime Linux/x86_64 4.7.585.gdec79
HTTP            [DEBUG]: > Connection: keep-alive
HTTP            [DEBUG]: > Accept: */*
HTTP            [DEBUG]: > Accept-Encoding: identity
HTTP            [DEBUG]: > Host: www.googleapis.com
HTTP            [DEBUG]: https://www.googleapis.com/youtube/v3/subscriptions: Response:
HTTP            [DEBUG]: < HTTP/1.1 204 No Content
HTTP            [DEBUG]: < Cache-Control: no-cache, no-store, max-age=0, must-revalidate
HTTP            [DEBUG]: < Pragma: no-cache
HTTP            [DEBUG]: < Expires: Fri, 01 Jan 1990 00:00:00 GMT
HTTP            [DEBUG]: < Date: Tue, 30 Dec 2014 08:40:05 GMT
HTTP            [DEBUG]: < ETag: "F9iA7pnxqNgrkOutjQAa9F2k8HY/7G2y8xeWVq9-yxUrvlxhacuUx5E" 
HTTP            [DEBUG]: < Vary: Origin
HTTP            [DEBUG]: < Vary: X-Origin
HTTP            [DEBUG]: < Server: GSE
HTTP            [DEBUG]: < Alternate-Protocol: 443:quic,p=0.02
HTTP            [DEBUG]: < 
HTTP            [DEBUG]: Parking connection to www.googleapis.com:443 (id=10)
Segmentation fault (core dumped)


Related issues

Related to Bug #2435: segfault if httpReq POST request receives HTTP/1.1 204 No... Fixed 12/30/2014

History

#1 Updated by Andreas Smas over 6 years ago

How do I reproduce it in youtube?

#2 Updated by Andreas Smas over 6 years ago

  • Status changed from New to Accepted

I can rep. it now

#3 Updated by Leonid Protasov over 6 years ago

  • Related to Bug #2435: segfault if httpReq POST request receives HTTP/1.1 204 No Content added

#4 Updated by Leonid Protasov over 6 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100

Fixed in 4.7.588

Also available in: Atom PDF