Bug #2382

APE is playing bad on PS3

Added by Slider Slider almost 6 years ago. Updated almost 6 years ago.

Status:FixedStart date:11/18/2014
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

100%

Category:Audio
Target version:4.10
Found in version:latest Platform:PS3

Description

FLAC play is ok but any one APE file is played with a freeze.

My Father_s Son.ape (30.5 MB) Slider Slider, 11/21/2014 06:08 PM

IMG_0292.MOV (51.5 MB) Slider Slider, 11/21/2014 06:08 PM

Associated revisions

Revision a27698f4
Added by Andreas Smas almost 6 years ago

audio: Try to output samples to audio drivers more often for huge frames

Fixes stuttering when playing certain type of containers/codecs (APE in particular)

Fixes #2382

Change included in version 4.9.8

History

#1 Updated by Leonid Protasov almost 6 years ago

Can you please attach a sample or a link?

#2 Updated by Slider Slider almost 6 years ago

I attached video sample and APE track. You can try play it. Look at the timer, sometimes step isn`t 1 sec.

#3 Updated by Leonid Protasov almost 6 years ago

  • Subject changed from Lossless APE bad play to APE is playing bad on PS3

On RPi it plays fine but steps in the playback status are not 1sec.

#4 Updated by Slider Slider almost 6 years ago

What is RPi?

#5 Updated by Leonid Protasov almost 6 years ago

Slider Slider wrote:

What is RPi?

http://en.wikipedia.org/wiki/Raspberry_Pi

#6 Updated by Slider Slider almost 6 years ago

Have you any news about fix?

#7 Updated by Leonid Protasov almost 6 years ago

  • Target version set to 4.10

#8 Updated by Leonid Protasov almost 6 years ago

Is this still reproducible on 4.9.x?

#9 Updated by Andreas Smas almost 6 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#10 Updated by Slider Slider almost 6 years ago

On 4.9. is all ok! Thanks, I very glad.

#11 Updated by Rural Hunter almost 6 years ago

Great. Seems this actually fixed my old problem Bug #1451.

Also available in: Atom PDF