Bug #2205

Black screen on HD channels

Added by Aleksandr Faronov almost 7 years ago. Updated over 6 years ago.

Status:FixedStart date:03/16/2014
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

100%

Category:HTSP client
Target version:4.8
Found in version:4.7.55 Platform:OS X

Description

All HD Channels show only audio and black screen


Related issues

Copied from Bug #2051: Black screen on HD channels Fixed 03/16/2014

Associated revisions

Revision 524c67a3
Added by Andreas Smas over 6 years ago

ps3: Filter out Access-Unit-Delimiters in h264 stream when playing HTSP

Tvheadend places those incorrectly and this causes the ps3 h264 cell decoder to barf

Fixes #2205

Change included in version 4.7.180

History

#1 Updated by Aleksandr Faronov almost 7 years ago

  • Copied from Bug #2051: Black screen on HD channels added

#2 Updated by Dreamcat 4 over 6 years ago

I have the same problem too. My current showtime version is 4.7.55.g3a6af on PS3

Here is a log. At the bottom we can see the channel France Eng. Video works (MPEG2 stream)

Then Last is NHK World HD. No video. codec h264 level 42.

https://gist.github.com/dreamcat4/06ee20dfb9ad9790429b

It would be nice to know if any other showtime versions will be a fix for this.

#3 Updated by Dreamcat 4 over 6 years ago

This problem only occur for me on ps3 builds of Showtime.
It does not happen on recent OS X builds (for me).

And whyz found ok on OS X build too. So I'm not sure the reasony Aleksandr has reported this bug on OS X platform. But it is definitely occurring on ps3. (any version of ps3 showtime).

#4 Updated by Dreamcat 4 over 6 years ago

on ps3 i have deleted all settings, deleted all cache folder, tried 3 different showtime version, problem always occurs

on ps3, can see no errors in log file. And "video bitrate" counter is updating constantly
just there is no video is output, screen remains black

#5 Updated by Dreamcat 4 over 6 years ago

One more thing - the same H264 .TS stream can be recorded in TVH Headend as a regular file. And accessed for example over SAMBA share. When played back that way, the video displays fine. So it must be some circumstance specific to live HTSP streaming!

When I look in backends/htsp/htsp.c there is almost no code in there which is specific to be only about H264. So I'm at a complete loss myself, unless there is something extra needed, which is currently missing for H264 but has been included for MPEG2 stream.

It's worth noting also the source I tested was a 1080p H264 TS Stream, over Gigabit LAN. Many thanks.

#6 Updated by Andreas Smas over 6 years ago

Good news. I know what's wrong now.

#7 Updated by Andreas Smas over 6 years ago

  • Target version set to 4.8

#8 Updated by Andreas Smas over 6 years ago

  • Status changed from New to Fixed

#9 Updated by Dreamcat 4 over 6 years ago

IT WORKS! Big thanks Andreas.

I can now watch HDTV channels on my PS3.
1080i H264 live.

Also available in: Atom PDF