Bug #2123

HLS playing problems (regression) (All platforms)

Added by Leonid Protasov almost 7 years ago. Updated almost 7 years ago.

Status:FixedStart date:05/01/2014
Priority:HighDue date:
Assignee:Andreas Smas% Done:

100%

Category:Video playback
Target version:4.6
Found in version:4.5.375 Platform:RPi


Related issues

Related to Bug #2118: Playing audio files over HTTP and continious play of HLS ... Fixed 04/30/2014
Related to Bug #2130: ST can't play some icecast playlists (All platforms) Fixed 05/03/2014

History

#1 Updated by Leonid Protasov almost 7 years ago

  • Related to Bug #2118: Playing audio files over HTTP and continious play of HLS are broken (regression) (All platforms) added

#2 Updated by Leonid Protasov almost 7 years ago

  • Subject changed from HLS playing problems (regression after http optimizations) to HLS playing problems (regression after http optimizations) (All platforms)

More detailed log: http://sprunge.us/LLhH

#3 Updated by Leonid Protasov almost 7 years ago

  • Subject changed from HLS playing problems (regression after http optimizations) (All platforms) to HLS playing problems (regression) (All platforms)

Looks like this is not related to http optimizations but more to continious play. The same link not playable via item list plays ok when pasted via webui. Still figuring out how to reproduce that.

#4 Updated by Leonid Protasov almost 7 years ago

Something with probing on continious play transition from one video to another http://sprunge.us/ZeOS

#5 Updated by Leonid Protasov almost 7 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Well Flashcom server wants ST to download m3u8 playlist in one go. To workaround that plugin was modified to open videos with "hls:" prefix. After that it works like magic.

#6 Updated by Leonid Protasov almost 7 years ago

  • Related to Bug #2130: ST can't play some icecast playlists (All platforms) added

Also available in: Atom PDF