Bug #1857

Spinner spins forever when opening movie via webserver's open URL

Added by Leonid Protasov almost 7 years ago. Updated almost 7 years ago.

Status:InvalidStart date:01/14/2014
Priority:HighDue date:
Assignee:Andreas Smas% Done:

0%

Category:Video playback
Target version:4.4
Found in version:4.3.716 Platform:RPi

Associated revisions

Revision b0376548
Added by Andreas Smas almost 7 years ago

Need to clear loading when playing video directly from URL

Fixes #1857

Change included in version 4.3.717

History

#1 Updated by Andreas Smas almost 7 years ago

  • Status changed from New to Invalid

I can't download the URL using curl or wget, in fact I can't even connect to the host

$ telnet farm2.3tv.im 80
Trying 193.111.83.36...

... nothing happens
aether:~ $ curl -v http://farm2.3tv.im/download/6a85ZnBw3lUGve_705HSmw,1389772491/films/8/4164/11356/720p_Plan.Pobega.2013.mp4 >/dev/null
* About to connect() to farm2.3tv.im port 80 (#0)
*   Trying 193.111.83.36...
* couldn't connect to host
* Closing connection #0
curl: (7) couldn't connect to host
aether:~ $

#2 Updated by Leonid Protasov almost 7 years ago

Still reproducible on RPI. There was temporal server down so try now:
http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4

Log:
00:00:28.180: navigator [INFO]:Opening http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4
00:00:28.208: thread [DEBUG]:Created detached thread: fa_open
00:00:28.935: HTTP [DEBUG]:http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4: switching to streaming mode
00:00:31.678: libav [DEBUG]:Short read wanted:32768 got:60
00:00:33.951: CEC [DEBUG]:RX: DeviceVendorID [0x87] (from:0x0 to:0xf) 00e091
00:00:34.110: CEC [DEBUG]:RX: FeatureAbort [0x00] (from:0x0 to:0x1)
00:00:35.128: Probe [DEBUG]: Stream #0: Video: h264 (High), yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 1076 kb/s
00:00:35.132: Probe [DEBUG]: Stream #1: Audio: aac, 48000 Hz, stereo, fltp, 128 kb/s
00:00:35.152: thread [DEBUG]:Thread fa_open exited
00:00:35.181: thread [DEBUG]:Created thread: PC:mp
00:00:35.192: thread [DEBUG]:Created thread: omxclkctrl
00:00:35.197: thread [DEBUG]:Created thread: video decoder
00:00:35.201: thread [DEBUG]:Created detached thread: video player
00:00:35.204: vp [DEBUG]:Waiting for event
00:00:35.210: vp [DEBUG]:Playing http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4 flags:0x1
00:00:35.238: media [DEBUG]:Settings initialized for URL http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4
00:00:35.267: AVSYNC [DEBUG]:Set to 0 ms
00:00:35.272: SVSYNC [DEBUG]:Set to 0s
00:00:35.777: HTTP [DEBUG]:http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4: switching to streaming mode
00:00:37.228: HTTP [DEBUG]:http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4: switching to streaming mode
00:00:38.993: libav [DEBUG]:Short read wanted:32768 got:60
00:00:41.800: Video [DEBUG]:Starting playback of http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4 (mov,mp4,m4a,3gp,3g2,mj2)
00:00:41.809: Probe [DEBUG]: Stream #0: Video: h264 (High), yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 1076 kb/s
00:00:41.812: Probe [DEBUG]: Stream #1: Audio: aac, 48000 Hz, stereo, fltp, 128 kb/s
00:00:41.818: Subscanner [DEBUG]:Starting subtitle scan for 720p_Plan.Pobega.2013 (imdbid:<unknown>;) year:0 season:-1 episode:-1 duration:6640 opensubhash:5aa7aeef4ba40966
00:00:41.825: thread [DEBUG]:Created detached thread: subscanner
00:00:41.830: Video [DEBUG]: Stream #0: Video: h264 (High), yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 1076 kb/s
00:00:41.861: Video [DEBUG]:Scanning for subs in http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/ for 720p_Plan.Pobega.2013
00:00:41.865: Video [DEBUG]: Stream #0: Codec created
00:00:41.868: Video [DEBUG]: Stream #1: Audio: aac, 48000 Hz, stereo, fltp, 128 kb/s
00:00:41.893: Video [DEBUG]: Stream #1: Codec created
00:00:41.897: thread [DEBUG]:Created thread: audio decoder
00:00:41.930: Video [DEBUG]:Selecting audio track libav:1
00:00:41.955: audio [DEBUG]:Codec changed to aac
00:00:41.990: HTTP [DEBUG]:http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/720p_Plan.Pobega.2013.mp4: switching to streaming mode
00:00:41.997: VideoCore [DEBUG]:Video decoder output port settings changed to h264 1280x720p (VideoCore)
00:00:42.002: TV [DEBUG]:State change 0x00000002 0x00000001 0x00000010
00:00:42.006: TV [INFO]:Display status = on
00:00:42.048: Video [DEBUG]:Unable to scan http://farm2.3tv.im/download/WA4WrG8fDqdtsNpcDDqGvg,1389842273/films/8/4164/11356/ for subtitles: Unhandled HTTP response 403
00:00:42.051: Audio [DEBUG]:Converting from [stereo 48000Hz fltp] to [stereo 48000Hz s16]
00:00:42.398: thread [DEBUG]:Thread subscanner exited

Video plays fine but throbber is spinning in the background forever...

Not reproducible on Linux but reproducible on PS3 too.

#3 Updated by Leonid Protasov almost 7 years ago

Fixed in 4.3.717.

Also available in: Atom PDF