Bug #1830

Showtime often completely hangs to blackscreen when rewinding(seek back) hls movies

Added by Leonid Protasov almost 7 years ago. Updated almost 7 years ago.

Status:FixedStart date:01/06/2014
Priority:NormalDue date:
Assignee:Andreas Smas% Done:

100%

Category:Video playback
Target version:4.4
Found in version:4.3.627 Platform:RPi

Description

The end of crashlog:
[DEBUG]:http://vs38.vcdn.biz/29d43c47efd7c5d7a4280dc8dae2c775_megogo/vod/fs/o/2036241/p/CUPERTINO/b/450_900_1350_1500/u_sid/0/u_uid/0/u_vod/3/u_device/samsung/g/ua/a/0/type.amlst/media-b1500000_23_sessionid_1975255373.ts: Response:
01:12:19.887: HTTP [DEBUG]: HTTP/1.1 200 OK
01:12:19.903: HTTP [DEBUG]: Date: Mon Jan 06 09:06:18 EET 2014
01:12:19.920: HTTP [DEBUG]: Accept-Ranges: bytes
01:12:19.934: HTTP [DEBUG]: Content-Type: video/MP2T
01:12:19.951: HTTP [DEBUG]: Server: FlashCom/3.5.7
01:12:19.967: HTTP [DEBUG]: Cache-Control: no-cache
01:12:19.981: HTTP [DEBUG]: Content-Length: 69748
01:12:19.998: HTTP [DEBUG]:
01:12:20.051: HLS [DEBUG]:Estimated bandwidth: 916368 bps (filtered: 916368 bps)
01:12:20.068: HTTP [DEBUG]:Parking connection to vs38.vcdn.biz:80 (id=133)
01:12:24.211: VideoCore [DEBUG]:Video decoder output port settings changed to h264 640x468p (VideoCore)
01:12:24.734: PANIC [EMERG]:OMX_SetupTunnel(src->oc_handle, srcport, dst->oc_handle, dstport): OMX Error (line:363) 0x80001018
01:12:24.742: CRASH [EMERG]:STACKTRACE (7 frames)
01:12:24.798: CRASH [EMERG]:panic+0x1c
01:12:24.806: CRASH [EMERG]:omx_tunnel_create+0x158
01:12:24.814: CRASH [EMERG]:rvd_set_codec+0x8c
01:12:24.821: CRASH [EMERG]:glw_set_video_codec+0x58
01:12:24.829: CRASH [EMERG]:rpi_codec_reconfigure+0x1c
01:12:24.837: CRASH [EMERG]:vd_thread+0x2d4
01:12:24.844: CRASH [EMERG]:thread_trampoline+0x5c

ST is completely hanging in blackscreen but I can login by ssh, do sync and reboot.

History

#1 Updated by Leonid Protasov almost 7 years ago

Blackscreen againg with complete ST hang:
[DEBUG]:http://vs32.vcdn.biz/edb49a74f4375fd53ca9fce415fdf509_megogo/vod/fs/o/2006631/p/CUPERTINO/b/450_900_1350_2000/u_sid/0/u_uid/0/u_vod/3/u_device/samsung/g/ua/a/0/type.amlst/media-b2000000_10_sessionid_2141012134.ts: Response:
00:03:34.693: HTTP [DEBUG]: HTTP/1.1 200 OK
00:03:34.701: HTTP [DEBUG]: Date: Mon Jan 06 11:29:51 EET 2014
00:03:34.709: HTTP [DEBUG]: Accept-Ranges: bytes
00:03:34.719: HTTP [DEBUG]: Content-Type: video/MP2T
00:03:34.730: HTTP [DEBUG]: Server: FlashCom/3.5.7
00:03:34.738: HTTP [DEBUG]: Cache-Control: no-cache
00:03:34.748: HTTP [DEBUG]: Content-Length: 1695760
00:03:34.758: HTTP [DEBUG]:
00:03:35.405: HLS [DEBUG]:Estimated bandwidth: 11918502 bps (filtered: 10008867 bps)
00:03:35.413: HTTP [DEBUG]:Parking connection to vs32.vcdn.biz:80 (id=24)

here i logged with putty synced and reboot
00:04:09.089: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.130: CONNMAN [DEBUG]:('Domains', <@as []>)
00:04:09.275: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.283: CONNMAN [DEBUG]:('Proxy', <{'Method': <'direct'>}>)
00:04:09.351: CONNMAN [DEBUG]:Manager-signal PropertyChanged from :1.0
00:04:09.432: CONNMAN [DEBUG]:('State', <'ready'>)
00:04:09.453: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.483: CONNMAN [DEBUG]:('State', <'disconnect'>)
00:04:09.505: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.512: CONNMAN [DEBUG]:('Timeservers', <@as []>)
00:04:09.534: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.552: CONNMAN [DEBUG]:('Nameservers', <@as []>)
00:04:09.570: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.580: CONNMAN [DEBUG]:('Domains', <@as []>)
00:04:09.599: CONNMAN [DEBUG]:Manager-signal PropertyChanged from :1.0
00:04:09.617: CONNMAN [DEBUG]:('State', <'idle'>)
00:04:09.624: CONNMAN [DEBUG]:Service-signal /net/connman/service/ethernet_b827eb5b1da3_cable PropertyChanged from :1.0
00:04:09.662: CONNMAN [DEBUG]:('State', <'idle'>)
00:04:09.670: CONNMAN [DEBUG]:Manager-signal TechnologyRemoved from :1.0
00:04:09.695: CONNMAN [DEBUG]:(objectpath '/net/connman/technology/ethernet',)
00:04:09.823: CONNMAN [DEBUG]:Manager-signal ServicesChanged from :1.0
00:04:09.830: CONNMAN [DEBUG]:(@a(oa{sv}) [], [objectpath '/net/connman/service/ethernet_b827eb5b1da3_cable'])
00:04:09.837: CONNMAN [DEBUG]:Deleted network /net/connman/service/ethernet_b827eb5b1da3_cable
00:04:09.845: CONNMAN [DEBUG]:agent method call: Release

#2 Updated by Leonid Protasov almost 7 years ago

One more:
[DEBUG]:http://vs32.vcdn.biz/edb49a74f4375fd53ca9fce415fdf509_megogo/vod/fs/o/2006631/p/CUPERTINO/b/450_900_1350_2000/u_sid/0/u_uid/0/u_vod/3/u_device/samsung/g/ua/a/0/type.amlst/media-b2000000_10_sessionid_1030734897.ts: Response:
00:05:35.558: HTTP [DEBUG]: HTTP/1.1 200 OK
00:05:35.576: HTTP [DEBUG]: Date: Mon Jan 06 11:36:17 EET 2014
00:05:35.597: HTTP [DEBUG]: Accept-Ranges: bytes
00:05:35.609: HTTP [DEBUG]: Content-Type: video/MP2T
00:05:35.636: HTTP [DEBUG]: Server: FlashCom/3.5.7
00:05:35.655: HTTP [DEBUG]: Cache-Control: no-cache
00:05:35.675: HTTP [DEBUG]: Content-Length: 1695760
00:05:35.693: HTTP [DEBUG]:
00:05:36.317: HLS [DEBUG]:Estimated bandwidth: 11185281 bps (filtered: 11007728 bps)
00:05:36.325: HTTP [DEBUG]:Parking connection to vs32.vcdn.biz:80 (id=30)
00:05:39.424: OMX [ERROR]:Timeout while waiting for buffer
00:05:42.436: OMX [ERROR]:Timeout while waiting for buffer
00:05:45.447: OMX [ERROR]:Timeout while waiting for buffer
00:05:48.459: OMX [ERROR]:Timeout while waiting for buffer
Picture here frozen and ST doesn't react to remote. But this time webui i accessible and i can see
OMX [ERROR]:Timeout while waiting for buffer - is fooding log.

#3 Updated by Andreas Smas almost 7 years ago

  • Status changed from New to Need feedback

hard to reproduce

#4 Updated by Leonid Protasov almost 7 years ago

  • Priority changed from High to Normal

#5 Updated by Leonid Protasov almost 7 years ago

  • Status changed from Need feedback to Fixed
  • % Done changed from 0 to 100

Can't reproduce anymore.

Also available in: Atom PDF