Bug #1801

NTFS doesn't appear , if plugged after Showtime starts

Added by lewlewlewl lewlewlewl almost 7 years ago. Updated almost 7 years ago.

Status:FixedStart date:12/09/2013
Priority:NormalDue date:
Assignee:lewlewlewl lewlewlewl% Done:

100%

Category:Filesystem
Target version:4.4
Found in version:latest (4.3.564-gb6cb6486) Platform:PS3

Description

It appears if I plug my ntfs drive before I launch Showtime but if I remove it or plug it after it's started, it wont show.

Associated revisions

Revision 554d30d4
Added by Andreas Smas almost 7 years ago

ps3: Fix bug causing NTFS drives not being able to be remounted

Fixes #1801

Change included in version 4.3.582

History

#1 Updated by Andreas Smas almost 7 years ago

  • Status changed from New to Need feedback
  • Assignee changed from Andreas Smas to lewlewlewl lewlewlewl

I can't reproduce this. It works fine for me (A USB stick)

Does the log say anything during this time?

It should be something like this:

NTFS [DEBUG]: Waiting for device 0 to settle
NTFS [DEBUG]: Waiting for device 0 to settle
NTFS [DEBUG]: Waiting for device 0 to settle
NTFS [DEBUG]: Waiting for device 0 to settle
NTFS [DEBUG]: Waiting for device 0 to settle
NTFS [DEBUG]: Mounted 1 partitions on device 0
NTFS [DEBUG]: Mounted ntfs0

#2 Updated by Rural Hunter almost 7 years ago

To me it's different. I have 2 drivers connected to my PS3, one FAT32 and another NTFS. When showtime is started and I plug off the NTFS driver, showtime crashed back to XMB immediately(I was not playing anything).

#3 Updated by lewlewlewl lewlewlewl almost 7 years ago

ok well now it appears when I plug it before launching Showtime. but If I unplug it and plug it back it won't show (Mounted 0 partition on device 0) so i unplug/plug it again in but it was still not showing.
after I decided to plug it into the other usb port and it showed, i unplugged and plugged again with this other port and the same thing happened (same log message)

#4 Updated by Andreas Smas almost 7 years ago

  • Status changed from Need feedback to Fixed
  • % Done changed from 0 to 100

Applied in changeset git|commit:554d30d4ccc8973fb55c2aa3525915fa531addd2.

#5 Updated by Andreas Smas almost 7 years ago

  • Target version set to 4.4

Also available in: Atom PDF