Bug #1788

UPnP in ST is broken from 4.3.200 (was fine in 4.3.188)

Added by iorgu delagl about 7 years ago. Updated almost 7 years ago.

Status:FixedStart date:10/27/2013
Priority:HighDue date:
Assignee:Andreas Smas% Done:

100%

Category:UPnP & DLNA
Target version:4.4
Found in version:Build #2713 - 4.3.200-g96f13d0 Platform:PS3

Description

I was using 4.2 on the ps3 with DVBViewer Recording Service and all working.

As this guy here - https://showtimemediacenter.com/boards/15/topics/8225 , i updated to the latest 4.3 to test.

I got the same bug : "when i click on a folder the same folder appears. somehow it's not possible to enter a subfolder in UPNP"

I went and got early 4.3 builds to find out exactly when things got broken.

I can report this:

- Build #2707 - 4.3.188-g9b57b5b - ps3 ----> All was perfect
- Build #2713 - 4.3.200-g96f13d0 - ps3 ----> Things are broken and you can't enter in any upnp folder

Working build display the discovered server as it should - http://s17.postimg.org/fo4zawbv3/dvbok.jpg
Even some broken ones do it right, but later ones start to show it like this, with a number - http://s23.postimg.org/otx9q6urv/dvbfail.jpg

Didn't have time to test in what build this server name bug comes up.

Hope someone finds out what went wrong from 2707 to 2713. I can test whatever is needed.

Associated revisions

Revision 0f324bfa
Added by Andreas Smas almost 7 years ago

upnp: Use URL to video file as canonical URL

Since we no longer need canonicalUrl in order to do continuous play we
are much better of keeping the object ID away from it.

One upside is that Showtime now recognizes the same move in terms of
'seen', playcount, etc even if viewed from different folders on a UPNP server.
Tested with Twonky and MiniDLNA

Fixes #1788 (I hope)

Change included in version 4.3.626

Revision ae8a8845
Added by Andreas Smas almost 7 years ago

upnp: One more fix

Fixes #1788

Change included in version 4.3.627

History

#1 Updated by Leonid Protasov almost 7 years ago

  • Subject changed from DVBViewer Recording Service is broken! I know exactly when it went bad! to UPnP in ST is broken from 4.3.200 (was fine in 4.3.188)
  • Priority changed from Normal to High

It's broken on all platforms (Linux/PS3/RPI).

#2 Updated by Leonid Protasov almost 7 years ago

  • Target version set to 4.4

#3 Updated by Andreas Smas almost 7 years ago

I think the regression was introduced with the fix in issue #1697

I really need to rethink how to fix this correctly

#4 Updated by Andreas Smas almost 7 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Applied in changeset git|commit:0f324bfac79701d86580e5674c121f3437844e0f.

Also available in: Atom PDF