Bug #1693

[PS3] Automatic "mark as seen" not working.

Added by Gert Mertes over 7 years ago. Updated almost 7 years ago.

Status:FixedStart date:04/21/2013
Priority:NormalDue date:
Assignee:Gert Mertes% Done:

100%

Category:User interface
Target version:4.4
Found in version:4.3.168 Platform:PS3

Description

The automatic "mark as seen" function after seeing a percentage of a video has stopped working somewhere around unstable release 4.3.168. I forgot which version exactly, but it was only a few unstable releases ago. I'd love to have this feature working again.

Manually marking a video "as seen" still works.

Associated revisions

Revision 7e39b262
Added by Andreas Smas over 7 years ago

upnp: Correctly bind playcount, restartpos metadata for video items

Fixes #1693

Change included in version 4.3.185

History

#1 Updated by Ema Nymton over 7 years ago

It still works for me with 4.3.179. Weird.

#2 Updated by Andreas Smas over 7 years ago

  • Status changed from New to Need feedback
  • Assignee changed from Andreas Smas to Gert Mertes

It could depend on where from the content is played.

Gert, what source are you playing from?

Plugin, UPNP, local disk or something else?

#3 Updated by Gert Mertes over 7 years ago

Playing from UPNP. Nothing changed server side, it just stopped marking videos as seen all of a sudden after an update.

#4 Updated by Andreas Smas over 7 years ago

  • Status changed from Need feedback to Fixed
  • % Done changed from 0 to 100

#5 Updated by Tony Miker over 7 years ago

The automatic mark as seen does not for me from Samba or USB only when the Percentage Required is set to 100%. Set it to 99% or lower, and it works fine.

#6 Updated by Tony Miker over 7 years ago

I should add that I've confirmed this bug in showtime-4.3.224-g91d3dd8 and also suspect that it may result from something like a rounding error in comparing the video duration with the playback position. Sometimes videos in the browser show a strange Duration that appears the same as the playback position, like "3:27 / 3:27", and then refuse to play unless play unless "Play from beginning" is used.

#7 Updated by Andreas Smas over 7 years ago

I've fixed the 100% bug. But please avoid reusing tickets for different issues.

#8 Updated by Andreas Smas almost 7 years ago

  • Target version set to 4.4

Also available in: Atom PDF