Bug #1049

Detect new dlna server

Added by Jean-Jacques Sarton about 8 years ago. Updated almost 8 years ago.

Status:InvalidStart date:07/05/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UPnP & DLNA
Target version:4.0
Found in version:3.99.43.g31afd Platform:Linux

Description

If the media server ist started after launching of showtime, it will not be offered. It will be nice to detect new media server as soon there are launched and announce themselve.
This don't work against minidlna.

History

#1 Updated by Jérôme S. about 8 years ago

I don't have this issue prior to 4.0. After a reboot of showtime do you see your minidlna server ?

PS: êtes vous français ? Je m'occupe de la traduction de showtime fr, et je traine ici depuis le début du projet. Si vous avez besoin de plus d'infos n'hésitez pas ;)

#2 Updated by Jean-Jacques Sarton about 8 years ago

For 3.99 showtime recognize minidlna if the server what started prior to showtime. If starting in
the opposite order occur, minidlna is not seen. At the start, minidlna send notify messages which normally should be seen by showtime. Actually detection seem only to work at startup.

PS: Je suis français mais je vie depuis 4 éternité en Allemagne, mes ordinateurs parlent nomalement cette dernière langue.

PPS: The Form elementa of am HTML page shall have the font site set (e.g. font-size:100%;).This make shure that the style is inherited from the parent element. Without this the fields may have wrong sizes.

#3 Updated by Andreas Smas almost 8 years ago

  • Status changed from New to Need feedback

I think this is fixed in latest versions of 3.99

Try 3.99.448 or later

#4 Updated by Andreas Smas almost 8 years ago

  • Category set to UPnP & DLNA

#5 Updated by Jean-Jacques Sarton almost 8 years ago

I just fetched the last version from github (Showtime 3.99.459.g74978). After compiling and starting showtime the application crashed. This what solved through deleting of the ~/.hts folder.
Now showtime start but complain about line 25 of the file showtime/glwthemes/mono/universe.view:

onEvent(menu, {
$ui.menu = !$ui.menu;
});

#6 Updated by Andreas Smas almost 8 years ago

you need to "make reconfigure"

#7 Updated by Jean-Jacques Sarton almost 8 years ago

reconfigure helped but the initial problem is always present. Minidlna and showtime run the same box. If I first start showtime and the minidlana, the click on local network showtime show a window with the text: "Discovered resources on local Network" and nothing more. Within this state tshowtime seem to hang, any further action is not possible.

#8 Updated by Andreas Smas almost 8 years ago

  • Status changed from Need feedback to Invalid

I'm sorry but I can't reproduce this.
I have MiniDLNA both on the same machine as I develop Showtime on and on one of my servers.
Both appears immediately in Showtime when I start it.

#9 Updated by Jean-Jacques Sarton almost 8 years ago

The bug shall be valid, even if it can't be reproduced.
If I start build-linux/showtime and there is NO upnp or dlna server and click on local network, showtime display only the text "discovered resource on local network" and don't react on any events (dlna server appear or mouse/key event).
This is all time reproducible here. The CPU load is very hight, I must use the nvidia driver, this possibly a reason for the problem.

Also available in: Atom PDF