libpulse0 dependency issue on Debian

Added by Daren K about 6 years ago

Ran into some dependency issue on Debian.

Debian uses a different version scheme without the epoch entry for libpulse0:

[email protected]:~/Downloads$ sudo dpkg -i showtime_4.10.25_amd64.deb
Selecting previously unselected package showtime.
(Reading database ... 251570 files and directories currently installed.)
Preparing to unpack showtime_4.10.25_amd64.deb ...
Unpacking showtime (4.10.25) ...
dpkg: dependency problems prevent configuration of showtime:
 showtime depends on libpulse0 (>= 1:1.0); however:
  Version of libpulse0:amd64 on system is 5.0-13.

dpkg: error processing package showtime (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 showtime

Can you fix this?

Anyway, my current workaround is to manually edit the dependency from libpulse0 (>= 1:1.0) to libpulse0 (>= 1.0) using this script: http://ubuntuforums.org/showthread.php?t=636724


Replies (1)

RE: libpulse0 dependency issue on Debian - Added by Andreas Smas about 6 years ago

This is caused by the dpkg build system that automatically insert dependencies. I'll override that list manually will come up in master soonish.

(1-1/1)