Error ./configure showtime

Added by icar povakov over 8 years ago

Hi !

I followed the "How to build for Linux" I install the required packages, but ./configure gives:

[email protected]:~/andoma-showtime-15a0d79$ ./configure
Configuring for Linux environment
Using C compiler:      cc
Using C++ compiler:    c++
Using Freetype2:       14.0.8
Using libfontconfig:   2.8.0
Using libX11:          1.4.99.1
Using libXext:         1.3.0
Using GLW Frontend:    x11
Using GL:              8.0.0
Using ALSA:            1.0.25
Using libpulse:        1.1
Using GTK+:            2.24.10
Using GTK Threading:   2.32.3
Using libxscrnsaver:   1.2.1
Using libxxf86vm:      1.1.1
Using libXv:           1.0.6
Using libcdio_cdda:    0.83
Using libcddb:         1.3.2
Using AVAHI client:    0.6.30
Using openssl:         1.0.1
Using libvdpau:        0.4.1
Found in cache: https://developer.spotify.com/download/libspotify/libspotify-12.1.51-Linux-i686-release.tar.gz
fatal: Not a git repository (or any of the parent directories): .git
Updating libav, submodule status = 
fatal: Not a git repository (or any of the parent directories): .git
Configuring libav...
support/configure.inc: ligne 319: /home/oxmoz/andoma-showtime-15a0d79/ext/libav/configure: Aucun fichier ou dossier de ce type
Configure failed
[email protected]:~/andoma-showtime-15a0d79$ 

I tried to install "libav" with the package manager but it did not change anything.

thank you in advance for anyone who helps me ;)


Replies (2)

RE: Error ./configure showtime - Added by Buksa Noob over 8 years ago

how you clone git? why yours showtime folder has hash at end?
just make a new fresh install
open terminal
remove all dependencies and delete andoma-showtime-15a0d79 folder

sudo apt-get -y autoremove git g++ libfreetype6-dev libfontconfig-dev libx11-dev libxext-dev mesa-common-dev libgl1-mesa-dev libasound-dev libpulse-dev libgtk2.0-dev libXss-dev libxxf86vm-dev libXv-dev libcdio-cdda-dev libcddb-dev libssl-dev libvdpau-dev curl yasm

then install dependencies

sudo apt-get update
sudo apt-get -y install git g++ libfreetype6-dev libfontconfig-dev libx11-dev libxext-dev mesa-common-dev libgl1-mesa-dev libasound-dev libpulse-dev libgtk2.0-dev libXss-dev libxxf86vm-dev libXv-dev libcdio-cdda-dev libcddb-dev libssl-dev libvdpau-dev curl yasm

then clone showtime git

cd
git clone --depth 1 git://github.com/andoma/showtime
cd showtime
./configure
make
make install

after if you need get new version just pull update from git

cd ~/showtime
make clean
git pull
./configure
make
make install

if you use virtualbox run showtime

cd ~/showtime
LIBGL_ALWAYS_SOFTWARE=1 build.linux/showtime

also you can read tutorial at http://www.facanferff.net/2012/09/how-to-build-install-showtime-ubuntu/

RE: Error ./configure showtime - Added by icar povakov over 8 years ago

Thank you Buksa Noob! it works well! thank you for the detailed explanation ;)

(1-2/2)