WiFi USB doesn't work

Added by Alexander Dulyasov almost 6 years ago

I use Dlink DWA-110 for my RPi. It works with Raspbian, but the Movian doesn't see the adapter. For fix it I got all Movian's files from .img and moved them into the Raspbian. It works (I had a lot of problems with HDMI-CEC but I solved it). I think it's very bad way.
Can you add USB WiFi drivers to the RPi STOS image or just make a .deb for the Raspbian?


Replies (5)

RE: WiFi USB doesn't work - Added by Leonid Protasov almost 6 years ago

Alexander Dulyasov wrote:

I use Dlink DWA-110 for my RPi. It works with Raspbian, but the Movian doesn't see the adapter. For fix it I got all Movian's files from .img and moved them into the Raspbian. It works (I had a lot of problems with HDMI-CEC but I solved it). I think it's very bad way.
Can you add USB WiFi drivers to the RPi STOS image or just make a .deb for the Raspbian?

But regarding http://elinux.org/RPi_USB_Wi-Fi_Adapters

DWA-110 (Version A1). Requires the ralink package from the non-free repository on Debian.

RE: WiFi USB doesn't work - Added by Alexander Dulyasov almost 6 years ago

It sounds sad. But the Raspbian already have all wifi drivers including the ralink for dwa-110. May release a .deb version for the Raspbian? I know it shouldn't be hard because I almost did it (without packing into the .deb and with manual hdmi-cec drivers installation).

RE: WiFi USB doesn't work - Added by Leonid Protasov almost 6 years ago

Alexander Dulyasov wrote:

It sounds sad. But the Raspbian already have all wifi drivers including the ralink for dwa-110. May release a .deb version for the Raspbian? I know it shouldn't be hard because I almost did it (without packing into the .deb and with manual hdmi-cec drivers installation).

Please tell more about hdmi-cec drivers. What is your TV brand/model and what drivers you use?

RE: WiFi USB doesn't work - Added by Alexander Dulyasov almost 6 years ago

My TV is Philips 42PFL7404. I just installed libcec and it works.
On STOS hdmi-cec works too, but I had to install libcec for using Movian on Raspbian.

(1-5/5)