Showtime PS3 firmware compatibility?

Added by Goku Son over 11 years ago

Hi all,

I tried installing Showtime in the past on my PS3, but got an install error as I assume the versions i had were probably for fw 3.41 and 3.55.  Is it possible to get Showtime to work for those of us still using older version firmware?  Would I need to compile a special version using PSL1GHT? Or does Showtime use a newer SDK than 3.15 and therefore not possible?

I'm still on 3.15 because i refuse to give up my OtherOS Linux on PS3..


Replies (16)

RE: Showtime PS3 firmware compatibility? - Added by Andreas Smas over 11 years ago

No idea actually. I only have 3.55 myself. Perhaps someone else knows more?

RE: Showtime PS3 firmware compatibility? - Added by Tiago windcrusher over 11 years ago

Showtime works at 3.41 too.

RE: Showtime PS3 firmware compatibility? - Added by pellopones loler over 11 years ago

ShowTime works perfect on 3.41....is very easy convert 3.55 version to 3.41 xDDDDD

RE: Showtime PS3 firmware compatibility? - Added by Max Jänsch over 11 years ago

hello,

not sure about this but i think all unsigned homebrew-apps should work on 3.15 and 3.41, so did you try an unsigned version of showtime?
after doing some research i finally found a signing tool that is working for me, unfortunaly it only works under windows. please try this pkg and report back, i don´t know the version of this file, but its zhe only one i can get my hands on right now. if it is working i´ll upload the latest version for you.

showtime-315.pkg (3.89 MB)

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Awesome! thanks Max! I'll try it tonight after work and report back.. hope it works.

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Well, I tried installing that .pkg, but unfortunately no joy, as it gave me error 80029563 i believe.. I tried to install the 3.41 version, just in case it might work, but it gave me a different error code.

Grrr..I can't wait until Linux is fully able to run natively on PS3 gameOS so i can finally update my firmware to a higher version.

Thanks for the replies however!

RE: Showtime PS3 firmware compatibility? - Added by Girish Patel over 11 years ago

Goku Son wrote:

Grrr..I can't wait until Linux is fully able to run natively on PS3 gameOS so i can finally update my firmware to a higher version.

Am I missing something here as can't you simply download an update for 3.41 or 3.55 and install it? I'm guessing its not that simple?

RE: Showtime PS3 firmware compatibility? - Added by Max Jänsch over 11 years ago

Goku Son wrote:

Well, I tried installing that .pkg, but unfortunately no joy, as it gave me error 80029563 i believe.. I tried to install the 3.41 version, just in case it might work, but it gave me a different error code.

Grrr..I can't wait until Linux is fully able to run natively on PS3 gameOS so i can finally update my firmware to a higher version.

Thanks for the replies however!

than i don't have any idea how to help you, sorry.
did you take a look at the otheros++ cfw to run linux? looks very promising to me but for some reason resizing the harddisc to install linux didn't work for me. but as you allready have linux on your harddisk maybe it's the fw you're looking for.

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Thanks,

yeah,i've been monitoring the news on it for a while, but it's still quite complicated, and their new prep tool is for v.3.55 only right now.  Most importantly, unless i'm mistaken, my original phat 60gb PS3 is NAND only, and the otheros++ uses vflash on the newer consoles right now.  That should all change with future development, but i'm waiting patiently till then.  =)

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

gizmo UK wrote:

Goku Son wrote:

Grrr..I can't wait until Linux is fully able to run natively on PS3 gameOS so i can finally update my firmware to a higher version.

Am I missing something here as can't you simply download an update for 3.41 or 3.55 and install it? I'm guessing its not that simple?

Yes, if i was willing to update to fw 3.41 or 3.55, it would probably work for me. My problem is once i go past fw 3.15, i lose my OtherOS feature thanks to stupid $ony. I want to keep my OtherOs feature, because i have Linux and Zerogame installed on it, which i use for my 40+ classic emulator gaming. So i'm stuck on 3.15 until linux runs on the PS3 GameOS, or someone comes out with a 3.41/3.55 cfw that doesn't lose the OtherOS linux option.

RE: Showtime PS3 firmware compatibility? - Added by Max Jänsch over 11 years ago

hi,
i'm pretty sure i saw a news yesterday that you can run petitboot on old consoles with NAND.
anyway, i guess you are using some kind of usb-dongle to jb your ps3, have you tried a different payload on it? maybe this could solve your install problems.

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Good point, No i haven't really gotten into trying different payloads yet, as there's a bunch of different versions which i wasn't sure would support 3.15 or my backup manager. I use my 4G ipod with the rockbox psgroove PL3 payload for now, but it makes it difficult to change payloads, as i would have to figure out how to compile it in a new rockbox.ipod file.

I started to look into it at one time, when DeanK told me the only way to mount backups with SELECT+X for Black Screen games you must have modified firmware 3.15 which supports peek+poke (or your dongle must provide payload which has peek+poke), but gave up. I may have to research it again when i can find some time, but i would need to purchase a dongle. Or maybe just buy another PS3, though i hate giving my money to $ony, and probably as soon as i do that, OtherOS will restored to cfw. =)

RE: Showtime PS3 firmware compatibility? - Added by Max Jänsch over 11 years ago

hi,
i found a site with diferent payloads for rockbox, maybe it's usefull for you: http://wiki.gbatemp.net/wiki/PSGroove_Rockbox#Files
don't know where you're from and how much shipping costs would be, but i have a diy-dongle with pic-processor flying around here. i don't need it anymore, so if you'd like to have it contact me.

RE: Showtime PS3 firmware compatibility? - Added by Matteo Plazzer over 11 years ago

Goku Son wrote:
...... I want to keep my OtherOs feature, because i have Linux and Zerogame installed on it, which i use for my 40+ classic emulator gaming. So i'm stuck on 3.15 until linux runs on the PS3 GameOS, or someone comes out with a 3.41/3.55 cfw that doesn't lose the OtherOS linux option.

I think there are others solutions for play classic game also on 3.55. Also with the last multiman there's already snes emulator installed....

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Nice!! Great find there Max! That site even explains some of the differences between all the different payloads which got confusing for me when i was searching. I'll experiment with a few of these and hope i don't permanently break something. The dongle sounds very appealing,(most generous of you), but my very crude UPS calculation of shipping from U.S Florida to Germany resulted in a minimum of $80 unfortunately. If I can refine that much lower, i'll contact you.

Thanks again Max, =) If i have any success, i'll post to share what i discover..

RE: Showtime PS3 firmware compatibility? - Added by Goku Son over 11 years ago

Matteo Plazzer wrote:

I think there are others solutions for play classic game also on 3.55. Also with the last multiman there's already snes emulator installed....

Yep, the emu list is growing, and I know that 3.55 is the future for many of the more resource intensive emulators (just saw a nintendo DS emu in the works). Still, right now in Linux, i have 40 emulators under 1 nice frontend (just added Turbografx-CD), with integrated youtube player, google search, and picture viewer. Would be nice to just bring that whole setup from OtherOs to GameOs for the greater speed and add more emu's, and of course to run showtime media center. Need to wait until all the emu's i currently use are running on 3.55, or i can run my linux setup on GameOs. Maybe buy a slim PS3 in the meantime..

(1-16/16)