Plugin download issues

Added by Anthony Liene over 6 years ago

Cant seem to download any plugins or get updates. Is the server down that they are on? I'm on latest testing version.


Replies (15)

RE: Plugin download issues - Added by Andreas Smas over 6 years ago

Can you attach logfile when this happens?

RE: Plugin download issues - Added by Andreas Smas over 6 years ago

(It works ok for me)

RE: Plugin download issues - Added by Anthony Liene over 6 years ago

How do I attach log file?

RE: Plugin download issues - Added by Anthony Liene over 6 years ago

ok I got it here it is

showtime-0.log (20.2 KB)

RE: Plugin download issues - Added by Anthony Liene over 6 years ago

I have my showtime log attached if anyone wants to chime in why I am having a problem downloading or updating plugins. says http error -1 if that helps.

RE: Plugin download issues - Added by Anthony Liene over 6 years ago

Now I connected my ps3 to my phone through a hotspot and it works http -1 error goes away (don't want to have it hooked up this way perm). now every other pc and tablet and program have no issues in my house. Has to be a setting in movian? If anyone makes sense of this let me know.

RE: Plugin download issues - Added by Leonid Protasov over 6 years ago

Anthony Liene wrote:

Now I connected my ps3 to my phone through a hotspot and it works http -1 error goes away (don't want to have it hooked up this way perm). now every other pc and tablet and program have no issues in my house. Has to be a setting in movian? If anyone makes sense of this let me know.

https://movian.tv/projects/movian/wiki/Logging

RE: Plugin download issues - Added by Buksa Noob over 6 years ago

same here
fresh install Ubuntu 14.04.2 LTS in VMware 10

showtime-0.log (20.2 KB)

--enable-polarssl.log - --enable-polarssl (23.4 KB)

RE: Plugin download issues - Added by Anthony Liene over 6 years ago

Can someone look at are attached logs and help us?

RE: Plugin download issues - Added by Andreas Smas over 6 years ago

Looking but i'm kind of clueless. I run the same things on Ubuntu 14.04 and it work just fine.

Even more weird that it works fine in wget.

Buksa, can you try to do the same thing but using

curl -v https://movian.tv/static/plugins/data/d2785bc74a83ecc26eaca2840eedb52405279c94 >/dev/null

So we can have a look at the headers and TLS setup?

Also I've improved the HTTP debug output so it's easier to see match request / response by adding an ID to each transfer.
It's in 4.9.393

Please do the same thing again with that version, thanks

RE: Plugin download issues - Added by Buksa Noob over 6 years ago

curl log at end

showtime-0.log (25.5 KB)

RE: Plugin download issues - Added by Buksa Noob over 6 years ago

different isp neighbors wifi
has access to plugins

showtime-0.log - neighbors wifi (24.8 KB)

RE: Plugin download issues - Added by Andreas Smas over 6 years ago

This is really confusing.

I've added even more HTTP debug in 4.9.396

So if you can please test again i'd be happy.

Thanks

RE: Plugin download issues - Added by Andreas Smas over 6 years ago

Found something that might be related to this problem: Try with 4.9.401

RE: Plugin download issues - Added by Buksa Noob over 6 years ago

same no access
http://sprunge.us/ENMY
http://sprunge.us/HjjZ --enable-polarssl
[email protected]:~/showtime$ curl -v https://movian.tv/static/plugins/data/d2785bc74a83ecc26eaca2840eedb52405279c94 >/dev/null
  • Hostname was NOT found in DNS cache
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0* Trying 2400:cb00:2048:1::681b:b008...
    0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0* Trying 104.27.177.8...
  • Connected to movian.tv (2400:cb00:2048:1::681b:b008) port 443 (#0)
  • successfully set certificate verify locations:
  • CAfile: none
    CApath: /etc/ssl/certs
  • SSLv3, TLS handshake, Client hello (1):
    } [data not shown]
    0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0* SSLv3, TLS handshake, Server hello (2): { [data not shown]
  • SSLv3, TLS handshake, CERT (11): { [data not shown]
  • SSLv3, TLS handshake, Server key exchange (12): { [data not shown]
  • SSLv3, TLS handshake, Server finished (14): { [data not shown]
  • SSLv3, TLS handshake, Client key exchange (16):
    } [data not shown]
  • SSLv3, TLS change cipher, Client hello (1):
    } [data not shown]
  • SSLv3, TLS handshake, Finished (20):
    } [data not shown]
  • SSLv3, TLS change cipher, Client hello (1): { [data not shown]
  • SSLv3, TLS handshake, Finished (20): { [data not shown]
  • SSL connection using ECDHE-ECDSA-AES128-GCM-SHA256
  • Server certificate:
  • subject: OU=Domain Control Validated; OU=PositiveSSL Multi-Domain; CN=sni94612.cloudflaressl.com
  • start date: 2015-04-08 00:00:00 GMT
  • expire date: 2016-02-18 23:59:59 GMT
  • subjectAltName: movian.tv matched
  • issuer: C=GB; ST=Greater Manchester; L=Salford; O=COMODO CA Limited; CN=COMODO ECC Domain Validation Secure Server CA 2
  • SSL certificate verify ok.

GET /static/plugins/data/d2785bc74a83ecc26eaca2840eedb52405279c94 HTTP/1.1
User-Agent: curl/7.35.0
Host: movian.tv
Accept: */*

< HTTP/1.1 200 OK
  • Server cloudflare-nginx is not blacklisted
    < Server: cloudflare-nginx
    < Date: Sat, 11 Apr 2015 13:02:27 GMT
    < Content-Length: 53745
    < Connection: keep-alive
    < Set-Cookie: __cfduid=d95d0043770d4e255526daacfd2f674551428757347; expires=Sun, 10-Apr-16 13:02:27 GMT; path=/; domain=.movian.tv; HttpOnly
    < Last-Modified: Wed, 2015 Apr 8 21:31:19 GMT
    < Cache-Control: public, max-age=31536000
    < CF-Cache-Status: HIT
    < Expires: Sun, 10 Apr 2016 13:02:27 GMT
    < CF-RAY: 1d56e2cc6734012b-SJC
    < { [data not shown]
    100 53745 100 53745 0 0 19710 0 0:00:02 0:00:02 --:--:-- 19708
  • Connection #0 to host movian.tv left intact

but it's ok i can use neighbours wifi and ISP
don't worry right now

(1-15/15)