Unable to open Cell codec. Error 0x80610180

Added by Dima Stan almost 8 years ago

After Updating to latest version (4.8) when I open any video I have this message: Unable to open Cell codec. Error 0x80610180

I don't know how fix it.
Pleas halp me!


Replies (24)

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Dima Stan wrote:

After Updating to latest version (4.8) when I open any video I have this message: Unable to open Cell codec. Error 0x80610180

I don't know how fix it.
Pleas halp me!

Running from multiman? What CFW are you on?

RE: Unable to open Cell codec. Error 0x80610180 - Added by Horst porst almost 8 years ago

Same issue here.

CFW 4.55, running from Multiman.
The error appeared right after the latest showtime update.
Any clues?

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Horst porst wrote:

Same issue here.

CFW 4.55, running from Multiman.
The error appeared right after the latest showtime update.
Any clues?

If you run directly from XMB - standalone ST version (installed manually from pkg), what do you see?

RE: Unable to open Cell codec. Error 0x80610180 - Added by Horst porst almost 8 years ago

Check!

manually install and starting from xbm works fine.
It now seems to be release 4.9.6. hmm, mabye I accidentally pick the wrong versions, don#t care about it as long as it works.

But the error still appears when using Multiman, even after update to ST 4.8.1
Is there any further infomation I should provide you to identify the bug?

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Horst porst wrote:

Check!

manually install and starting from xbm works fine.
It now seems to be release 4.9.6. hmm, mabye I accidentally pick the wrong versions, don#t care about it as long as it works.

But the error still appears when using Multiman, even after update to ST 4.8.1
Is there any further infomation I should provide you to identify the bug?

Something wrong is going on when ST is run from MultiMan. Andreas (the Showtime author) doesn't support ST working under MultiMan AFAIK. So looks like you need to use standalone version.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Horst porst almost 8 years ago

Ok, so in my opinion this case is closed as I have a sufficent solution.
thanks for your help.
:)

RE: Unable to open Cell codec. Error 0x80610180 - Added by Max Pot almost 8 years ago

Please tell me how to downgrade Showtime PS3 test version to stable ? Even after uninstalling and reinstalling it sees a test version. In what directory it keeps its updates? Showtime run's from multiman.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Max Pot wrote:

Please tell me how to downgrade Showtime PS3 test version to stable ? Even after uninstalling and reinstalling it sees a test version. In what directory it keeps its updates? Showtime run's from multiman.

https://showtimemediacenter.com/downloads/showtime/master

RE: Unable to open Cell codec. Error 0x80610180 - Added by Ano nymus almost 8 years ago

Max Pot wrote:

Please tell me how to downgrade Showtime PS3 test version to stable ? Even after uninstalling and reinstalling it sees a test version. In what directory it keeps its updates? Showtime run's from multiman.

I got the same problem even if i uninstall showtime and reinstall using the stable version downloaded from this site it always come up with the testing stage one and it's buggy oro and yts doesnt work ...

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Ano nymus wrote:

Max Pot wrote:

Please tell me how to downgrade Showtime PS3 test version to stable ? Even after uninstalling and reinstalling it sees a test version. In what directory it keeps its updates? Showtime run's from multiman.

I got the same problem even if i uninstall showtime and reinstall using the stable version downloaded from this site it always come up with the testing stage one and it's buggy oro and yts doesnt work ...

Set in Settings->Bleeding Edge

RE: Unable to open Cell codec. Error 0x80610180 - Added by Ano nymus almost 8 years ago

It doesnt solve the case ... I don't want the testing versions i want 4.8 version back :(

RE: Unable to open Cell codec. Error 0x80610180 - Added by Andreas Smas almost 8 years ago

You can find all previous builds here: https://showtimemediacenter.com/builds/showtime

As far as I am concerned it seems that the 0x80610180 error only occurs if Showtime is started from Multiman and thus it must somehow be correlated to Multiman. That said it seems that older versions of Showtime is not affected.

I don't have Multiman myself (and no intentions of installing it). If someone really wants to help figuring out what went wrong here find an old version of Showtime (all builds can be found in the link above) that works with Multiman and bisect versions until you found the exact version that breaks.

Good luck

RE: Unable to open Cell codec. Error 0x80610180 - Added by Leonid Protasov almost 8 years ago

Andreas Öman wrote:

You can find all previous builds here: https://showtimemediacenter.com/builds/showtime

As far as I am concerned it seems that the 0x80610180 error only occurs if Showtime is started from Multiman and thus it must somehow be correlated to Multiman. That said it seems that older versions of Showtime is not affected.

I don't have Multiman myself (and no intentions of installing it). If someone really wants to help figuring out what went wrong here find an old version of Showtime (all builds can be found in the link above) that works with Multiman and bisect versions until you found the exact version that breaks.

Good luck

I will add my 5 cents: why just to not ask deank to install ST as standalone? That's imho the most convenient way and will stop new errors to appear in the future because of integration...

RE: Unable to open Cell codec. Error 0x80610180 - Added by Alex Cool over 7 years ago

Decision error 0x80610180 and brakes Showtime fairly simple. Enough to run Showtime not through Multiman, and from the regular menu (XMB).;) :)

RE: Unable to open Cell codec. Error 0x80610180 - Added by Dean Kasabow over 6 years ago

I know it is quite an old thread, but I wanted to let you know about the issue with Movian when started from multiMAN. What puzzled me was that the exact same code works fine in the standalone Movian version, but causes the fatal error in the "showtime.self" from multiMAN.

I believe I wrote about this before, but the only change that fixed it is to lower the spu_threads to 3 (from 4):

in src/arch/ps3/ps3_vdec.c

spu_threads = 3;

I guess because Movian is spawned from another app it takes one SPU and makes it unavailable for movian. Anyway, it works just fine decoding 1920x1080 H.264 + 5.1 AC3 audio in the latest Movian 05.00.002.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Rob Koni about 6 years ago

Dean Kasabow wrote:

I know it is quite an old thread, but I wanted to let you know about the issue with Movian when started from multiMAN. What puzzled me was that the exact same code works fine in the standalone Movian version, but causes the fatal error in the "showtime.self" from multiMAN.

I believe I wrote about this before, but the only change that fixed it is to lower the spu_threads to 3 (from 4):

in src/arch/ps3/ps3_vdec.c

spu_threads = 3;

I guess because Movian is spawned from another app it takes one SPU and makes it unavailable for movian. Anyway, it works just fine decoding 1920x1080 H.264 + 5.1 AC3 audio in the latest Movian 05.00.002.

See https://movian.tv/issues/3186

It isn't fixed with me in 5.0.308 so should it be a Movian or Multiman fix?

RE: Unable to open Cell codec. Error 0x80610180 - Added by Dean Kasabow about 6 years ago

The fix is for the version of Movian, which is distributed with multiMAN (either the build-in SHOWTIME.SELF, or the standalone version from mM's web column).

RE: Unable to open Cell codec. Error 0x80610180 - Added by Rob Koni about 6 years ago

Dean Kasabow wrote:

The fix is for the version of Movian, which is distributed with multiMAN (either the build-in SHOWTIME.SELF, or the standalone version from mM's web column).

So how to fix it? Since I updated Movian within Multiman and the error remains. It updates the SELF

RE: Unable to open Cell codec. Error 0x80610180 - Added by Dean Kasabow about 6 years ago

Either download the standalone Movian from the web column and install it or update SHOWTIME.SELF from the Video column (do not update movian from movian). The current version for multiMAN is 5.00.308 and it should work for you (I compiled it 15 mins ago).

From your log I can see that you're not using the proper version, because mM's Movian stores its settings in /st4_settings and not in /settings.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Rob Koni about 6 years ago

Dean Kasabow wrote:

Either download the standalone Movian from the web column and install it or update SHOWTIME.SELF from the Video column (do not update movian from movian). The current version for multiMAN is 5.00.308 and it should work for you (I compiled it 15 mins ago).

From your log I can see that you're not using the proper version, because mM's Movian stores its settings in /st4_settings and not in /settings.

Very informative. Ah that was the error I think, I updated Movian within Movian. How to update the SHOWTIME.SELF?

I was hoping that Multiman would use the stand alone Movian installed under XMB as this is quite confusing.

Could you also please answer my e-mail :)

RE: Unable to open Cell codec. Error 0x80610180 - Added by Dean Kasabow about 6 years ago

In multiMAN go to the VIDEO column, press <Triangle> and you'll see "Update Showtime" option. Or you can go to the WEB column and download the pkg and install it from XMB. In either case you should never update movian within movian, because you'll get the problem with the CellCodec because of insufficient numbers of SPUs.

If your email is about RPi-Zero and Movian - I don't have Zero to debug the issue... you should use the official SD-image, which is provided by Andreas here.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Rob Koni about 6 years ago

Dean Kasabow wrote:

In multiMAN go to the VIDEO column, press <Triangle> and you'll see "Update Showtime" option. Or you can go to the WEB column and download the pkg and install it from XMB. In either case you should never update movian within movian, because you'll get the problem with the CellCodec because of insufficient numbers of SPUs.

If your email is about RPi-Zero and Movian - I don't have Zero to debug the issue... you should use the official SD-image, which is provided by Andreas here.

Yup that's my e-mail. I can do some debugging once I fire up my TTL cable. Can send to your e-mail.

RE: Unable to open Cell codec. Error 0x80610180 - Added by zTGo_ Sparrow about 6 years ago

Dima Stan wrote:

After Updating to latest version (4.8) when I open any video I have this message: Unable to open Cell codec. Error 0x80610180

I don't know how fix it.
Pleas halp me!

Reinstall movian, delete, download , install and play. I was facing the same problem and thats how i fixed it.

RE: Unable to open Cell codec. Error 0x80610180 - Added by Rob Koni over 5 years ago

Dean Kasabow wrote:

In multiMAN go to the VIDEO column, press <Triangle> and you'll see "Update Showtime" option. Or you can go to the WEB column and download the pkg and install it from XMB. In either case you should never update movian within movian, because you'll get the problem with the CellCodec because of insufficient numbers of SPUs.

If your email is about RPi-Zero and Movian - I don't have Zero to debug the issue... you should use the official SD-image, which is provided by Andreas here.

I found a very strange thing. I launch some discs from Multiman into Movian and it does not give me the 0x80610180 error, but with IrisMan 4.81.1 it does.
As IrisMan uses the Movian.self from it's own directory, I CRC compared them. They are the same.

Why is that? Aldo says that there is nothing different. Is there a specific fix in Multiman implemented to fix this?

I don't know what is wrong.

(1-24/24)