Split mkv playback problems

Added by | Benzonia | over 8 years ago

I've using Showtime 4.2, playing mkv files I've created from BluRay discs, using HandBrake for the encoding. On larger movies (like The Matrix, for example), the HD file comes out at like 6GB or 7GB in size. Due to the FAT32 file size restrictions, I've archived them using WinRAR, splitting them into 3.7GB chunks using the Store method.

Showtime plays the files great, except for a 10-20 minute window somewhere in the middle of the movie. For that 10-20 minutes of playtime, the video gets extremely choppy due to the buffer running out. Pressing square confirms the buffer is empty. I'm guessing this must be the point in the mkv where the rar split the file, but I thought Showtime fully supported that?

Does anyone have any information about what could be going wrong? Or maybe what I can do to prevent it? My only solution thus far is just to pause the movie, wait for the buffer to refill, then start again -- which only lasts about 20 more seconds of playback until I have to repeat. Annoying, right?


Replies (3)

RE: Split mkv playback problems - Added by Rural Hunter over 8 years ago

The latest version of showtime supports direct split files(file names end with .001, .002 etc). You can use file split tools to generate those files easily and fast(on windows, I recommand ffsj). If you can not find the latest official build, you can try my build here: http://pan.baidu.com/share/link?shareid=411883&uk=1946468641
I added a customized font in my build and used it as default font.

RE: Split mkv playback problems - Added by | Benzonia | over 8 years ago

Hey thanks, that's a huge help! I didn't even know split files were supported.

On my first try, it didn't work in the stand-alone Showtime. I split a movie into 2 parts, watched from the beginning, and about 1 hr 29 min into it the playback just stopped at a black screen. I'm guessing that was where the file split occurred. I tried playing the file again, thinking it'd resume playback at that point and continue on, but it stayed at a black screen. No crash though, I still had control. I then tried the file again from the beginning, and fast-forwarded to 1:29 to see if it'd do better, but no luck.

I then tried booting multiMAN and used the version of Showtime from there. I don't recall the version number, but it did work playing the split file. Wonder what the difference is.

Anyone think I should submit a bug report? Maybe try a second file?

RE: Split mkv playback problems - Added by Rural Hunter over 8 years ago

If the problem occurs on my build, I don't think you should submit a bug report. What tool did you use to split the file? What are the file names after split? and how do they appear in showtime file browser?

(1-3/3)