Crash when go to settings

Added by Peter Marak almost 10 years ago

Hi, everytime i want to go to the settingsmenu showtime crashesback to xmb! Doesn´t matter which version i install...Somebody who know´s why?


Replies (28)

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Can you paste a logfile?

See logging

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Check via the web interface instead (described on the same page)

RE: Crash when go to settings - Added by Jerome Morrow almost 10 years ago

Have you tried to do a new and clean installation??

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Sure i tried! I already formatted my HDD, the reinstalled Showtime, same Problem!

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Seems you're running it form multiman.

Is it the same problem if you run Showtime standalone?

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Hi, yes i already tried both! Standalone same Problem!

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

That´s the log of the Standalone...

showtime.log (17.8 KB)

RE: Crash when go to settings - Added by Steve Folland almost 10 years ago

Peter Marak wrote:

Hi, everytime i want to go to the settingsmenu showtime crashesback to xmb! Doesn´t matter which version i install...Somebody who know´s why?

Hi, I have exactly the same problem, it also occurs when one tries to connect to 'Local Network' it just quits back to the XMB.

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

I think the problem is that Showtime for some reason crashes when it tries to display an UPNP/DLNA icon. (They are both showed in settings and in local nework so it seems to match the observations in this thread)

Could be some bug in the JPEG decoder or so.

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Yee that must be the problem! Cause only if i want to access my NAS or go to Settings it crashes...What can i do?

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Will you fit it pls?! That would be awesome....

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Ok, but I need your help.

First in the top search bar on the home page type

settings:dev <enter>

This will open a settings menu with some stuff.

Enable "Debug all HTTP requests"

Then go visit the normal settings -> Showtime will crash.

Extract the most recent logfile as described here: logging

Paste that logfile here, it will include the URL to the offending icon.

If you can't figure that out yourself i'll help you (it's a raw hexdump of the HTTP headers, etc)

Then i'll ask you to download that icon and attach it here as a file.

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

i don´t understand where i have to type in: settings:dev... Which Homepage?

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

On the first page when you start showtime.

Top search bar

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

ok, i will do it tomorrow, today i am not at my ps3! Tomorrow i will post all the things you need...:)

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Maybe it´s that Icon?!

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Yes, that seems to crash Showtime. I'll fix it tonight.

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Wow THX! Appreciate it...:)

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

OK so here's the problem.

The PNG is in 16bit color depth (instead of normal 8 bits per color)

Showtime cannot decode the PNG but fails to recognize the error and then crashes.

I'm not gonna fix 16bit support for PNG (I use the PNG decoder from libavcodec)
but i'm gonna make sure it does not crash at least.

RE: Crash when go to settings - Added by Andreas Smas almost 10 years ago

Version 4.1.419 is soon published to testing and available for download on ps3.

It will have the fix.

RE: Crash when go to settings - Added by Peter Marak almost 10 years ago

Ok cool THX! Is it updateable over Multiman?! Or can i just change the icon then from my NAS Server in 8bit?!

1 2 (1-25/28)