No subtitles when watching movies over uPnP

Added by Philipp Grosswiler over 11 years ago

I am using MiniDLNA and TwonkyServer to serve my movies to Showtime on the PS3 which works very well. But Showtime seems not to be able to load any subtitles whether they are included in the MKV container or as an external SRT/SUB file. The log indicates a request is sent to the server but with no file to load (yielding in an 404 response). Can anyone confirm this? Is it possible to use subtitles over uPnP with Showtime at all?


Replies (30)

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

I have made some more tests over the weekend and found out that subtitles don't work at all on the PS3 using the latest version (showtime-GIT-2.99.254.g2fc37). I copied a movie (Matroska) to the PS3's internal HDD and it didn't show the subtitles. The movie had subtitles included in the file, and also the external subtitles (SRT/SUB/IDX) didn't work.

As mentioned in other threads on this forum, subtitles were once working. Can anyone else confirm that it is not working in the current version?

RE: No subtitles when watching movies over uPnP - Added by Sebastian Pettersson over 11 years ago

I haven't been able to get any subtitles to load in the latest version...

RE: No subtitles when watching movies over uPnP - Added by Pedro Igreja over 11 years ago

I can load them just fine, included in the mkv and loaded from upnp.

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

What version did you use? I am using the latest version for PS3 (showtime-GIT-2.99.254.g2fc37.pkg) and it does definitely not work (I tried multiple movies with internal and external subtitles either directly on HDD or via UPnP). And as Sebastian confirms, it's also not working for him.

RE: No subtitles when watching movies over uPnP - Added by Jan Aydin over 11 years ago

You have to enable subtitles for each playback.

Press the triangle button to see the menu in the lower part of the screen. Then select the arrow at the rightmost edge of the menu, click x and now you should see another menu where you can choose audio and subtitles. Works flawlessly

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

Thank you for the hint! I will try it out as soon as possible. But I have to say, it's not quite obvious. Isn't there a way to use subtitles automatically (like when you say which languages you prefer). But if I know the workaround, I am already happy!

RE: No subtitles when watching movies over uPnP - Added by Matteo Plazzer over 11 years ago

I'm sorry but how you can see video from upnp source?...the last version has Bug #418 and no works anymore...

RE: No subtitles when watching movies over uPnP - Added by Sebastian Pettersson over 11 years ago

I have enabled subtitles in the menu but they still don't show. All I've tried have been external srts, not inside the mkv files. Maybe I've just been unlucky with the movies I've tried...

RE: No subtitles when watching movies over uPnP - Added by Pedro Igreja over 11 years ago

I've only installed showtime a few days back i my media server showed right away, my server is in a buffalo NAS. external subs don't work from UPnP, and i inserted the srt in the video myself with "mkvtoolnix"

hope this helps.

RE: No subtitles when watching movies over uPnP - Added by Sebastian Pettersson over 11 years ago

Ok, I just tried another video with external subs. Guess I've just been unlucky.

RE: No subtitles when watching movies over uPnP - Added by Andreas Smas over 11 years ago

external subs over UPNP does not work. So you don't need to keep trying :-)

RE: No subtitles when watching movies over uPnP - Added by Björn Ericsson over 11 years ago

Is there lists of what should work and what should not?

/BE

RE: No subtitles when watching movies over uPnP - Added by Andreas Smas over 11 years ago

No, I'm afraid not :-(

I really should write an (up 2 date) FAQ

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

I can confirm this. External subtitles over UPnP doesn't work, but if they are embedded into the video it works without problems.

Are there any plans to make this work for external subtitles as well?

RE: No subtitles when watching movies over uPnP - Added by Andreas Smas over 11 years ago

Yes I will fix it. Right now I try to focus on getting all characters encoding work with subtitles

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

Thank you very much for your great work! I really love Showtime!

By the way, while you are fixing the subtitles, also check out the space for displaying the subtitle language names (e.g. "Norwegian" is cut off at the end).

RE: No subtitles when watching movies over uPnP - Added by Matteo Plazzer over 11 years ago

I'm sorry if still join into discussion with an OT but nobody has answer me about....how you can use showtime with upnp source? I've (like all I supposed..) bug #418....the subtitles for me aren't importants ;-).

PS: Thx Andreas for great job!

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

Hello Matteo. I am using MiniDLNA or TwonkyServer to access my media files over UPnP. Both of them work without any problems using the latest version of Showtime for the PS3. I guess it's because they don't use the real path names but aliases which don't use special characters. That's why it works. Give it a try!

RE: No subtitles when watching movies over uPnP - Added by Matteo Plazzer over 11 years ago

Thx Philipps....anyway I'm using twonkyserver but for me doesn't work. I'll try to remove special characters from files names, but I think will doesn't work...

RE: No subtitles when watching movies over uPnP - Added by Philipp Grosswiler over 11 years ago

What version of TwonkyMedia Server are you using? I am using version 6.0.32. When I start a movie, it says someting like O0$3$28I16909 and that's the alias. If you press R3 to see the log, what URL is it trying to open? Mine looks like this: http://192.168.2.115:9000/disk/DLNA-PNMKV-OP01-FLAGS01700000/O0$3$28I16909.mkv and that's when it works :)

RE: No subtitles when watching movies over uPnP - Added by Matteo Plazzer over 11 years ago

I'm using qpkg for qnap nas and the last version is the 6.0.30....now I don't remember the complete url (this evening I'll check...) but the same problem occours to open mp3 and photos. This tell me that the special charapter of mkv files names isn't the problem.

RE: No subtitles when watching movies over uPnP - Added by Matteo Plazzer over 11 years ago

Philipp...I've checked I've pressed R3 for the log but it doesn't report any error...I can see only the string like at your, maybe there isn't the "FLAGS070000" part....

RE: No subtitles when watching movies over uPnP - Added by Özgün Can Özgüneş over 11 years ago

What simple and basic and free upnp-dlna software you suggest for Windows, for streaming .mkvs with subtitle to PS3 Showtime?

RE: No subtitles when watching movies over uPnP - Added by Sebastian Pettersson over 11 years ago

I just wanted to say that subtitles works much better now in the latest version. Thanks for a great release and an awesome piece of software!

RE: No subtitles when watching movies over uPnP - Added by Nuno Grilo over 11 years ago

The way showtime uses to load subtitles doesn't work with minidlna.
Showtime makes a HTTP request to the parent URL of the video expecting to receive an html index containing a link to the subtitle file.
minidlna doesn't support this and returns a 404 error.
To get subtitles working with minidlna, showtime should make an HTTP HEAD request to the video URL with the following HTTP header:

getCaptionInfo.sec: 1

In return minidlna will output a response header with the URL to the subtitle:

CaptionInfo.sec: http://<server>:8200/Captions/<id>.srt

Would it be possible to implement this feature in showtime?
I could provide a patch but I can't get showtime to compile, it complains about a missing header file from libav and I don't know how to compile and install libav

1 2 (1-25/30)