UPnP is not working at all

Added by Roki Krako almost 12 years ago

Hi

I have version 2.99.176 and still UPnP is not working at all, strange that nobody noticed this...

When I tried play anything from UPnP server (in my case TwonkeyMedia server on QNAP NAS) I see always "Unable to open resourse. Invalid HTTP 200 response".

I checked log and problem is that Showtime is trying some strange URL. The correct URL for video from web browser of TwonkeyMedia is for example:

http://192.168.1.110:9000/disk/video/O0$3$27I762/30%20Rock%20-%201x01%20-%20Pilot.avi

Showtime is trying open this link

http://192.168.1.110:9000/disk/DLNA-PNAVI-OP01/video/O0$3$27I762/30%20Rock%20-%201x01%20-%20Pilot.avi

thx


Replies (12)

RE: UPnP is not working at all - Added by Henrik Uhrenfeldt almost 12 years ago

Hi,

I have the exact same problem. MKVs are served through MediaTomb and I see the above "Invalid HTTP 200 response"..

Previously it has worked for me, so I guess it is a recent commit giving the problems.

I can see that some changes have been done recently to fa_http.c

https://www.lonelycoder.com/redmine/projects/showtime/repository/revisions/4836c7d022c87d1dd4c6080060f99d1aa4cae8d6/diff/src/fileaccess/fa_http.c

I cannot argue why it would produce the exact error we see, but once I get some spare time, I will this commit (or parts of it) and test if it solves the problem.

- Henrik

RE: UPnP is not working at all - Added by Mattias Wadman almost 12 years ago

Hmm that change should not effect this. But have a look at https://github.com/andoma/showtime/commits/master/src/upnp for anything suspicious.
Do you know the date of the source when it last worked?

RE: UPnP is not working at all - Added by Justin Case almost 12 years ago

I'm having the exact same "Invalid HTTP 200 response". Hopefully this will get fixed soon.

RE: UPnP is not working at all - Added by Tom Mottom almost 12 years ago

i have also the same problem with my Buffalo Linkstation NAS and its twonkymediaserver installed.

it doesn't show the correct path to the files. Only exception is, i can see the preview of pictures on the right, when i mark a pic.

i hope you set this problem to your mainfocus, because this is atm the onliest way to avoid the 4 GB filesizelimit of the hdd :) When you stream your files to the ps3 it doesn't matter how big the file on the NAS is ;) A playlist would also be nice.

after all i have to say, that this is already my favourite homebrew for the ps3 ever made. Thank you for all your hard work Andreas and i hope you are fine with my feedback.

:wave:

RE: UPnP is not working at all - Added by Tom Mottom almost 12 years ago

i just tried out your latest release. Though the changelog says "upnp: Use videoparams:{} when launching video to get correct title" it still doesn't work with the linkstation and twonky on it.

Do i do anything wrong or can i edit the settings for it anyhow to make it work?

Thanks for your hard work. Much appreciated!

RE: UPnP is not working at all - Added by Özgün Can Özgüneş almost 12 years ago

What simple and basic and free upnp-dlna software you suggest for Windows, for streaming .mkvs with subtitle to PS3 Showtime?

RE: UPnP is not working at all - Added by Leif Arvidsson almost 12 years ago

Hi i experience the same problem with "Invalid HTTP 200 Response" I have a Buffalo Linkstation Pro Duo Nas... I wonder if this is a router problem or if the problem is a bug in the code... Do anybody know a fix for this problem or is it software issue??

RE: UPnP is not working at all - Added by Roki Krako almost 12 years ago

It is bug in Showtime code as I already explain in 1st post here.

RE: UPnP is not working at all - Added by Tom Mottom almost 12 years ago

did you fix it for your personal version or is it a big deal to do so? i really need that working to be able to use showtime.

RE: UPnP is not working at all - Added by open ps3 almost 12 years ago

I use Mediatomb and the Orginal Sony Player playes all Files perfect.
Showetime do nothing

RE: UPnP is not working at all - Added by Leif Arvidsson almost 12 years ago

Its not the point is it. I want to be able stream directly from my nas and play natively from PS3....

RE: UPnP is not working at all - Added by Tom Mottom almost 12 years ago

are you working on it Andreas?

if that works I'll donate instead of just saying thanks :)

(1-12/12)